Back to the main site

Shadow of the tomb raider doesn't play (Integrated graphics processor)

Shadow of the tomb raider (Windows Iso) when I click play, it flashes a black screen and closes the game:

Linux Mint 20.2 Cinnamon x64 X11
kernel: 5.4.0-81-generic

Lutris: 0.5.8.4
Wine version: lutris-fshack-6.14-3-x86_64
Enabled DXVK/VKD3D
DXVK version: v1.9.1L

Integrated graphics processor: AMD Ryzen 5 3400g

full log:

glxinfo | grep ‘version’

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
Max core profile version: 4.6
Max compat profile version: 4.6
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.2.1 - kisak-mesa PPA
OpenGL core profile shading language version string: 4.60
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.2.1 - kisak-mesa PPA
OpenGL shading language version string: 4.60
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.2.1 - kisak-mesa PPA
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
GL_EXT_shader_group_vote, GL_EXT_shader_implicit_conversions,


How to fix this, and load the game?

1 Like

What have you tried to get it to run?

I didn’t make any changes via winetricks, I left everything original as Lutris installs

I just added the game via the Add Game… button, installed via iso in a wineprefix ~/Jogos/Shadow_TR. runner I set Wine (Windows).

03

When entering the game, in options, if I leave the Directx12 option activated, and go to play, it happens the same as the video, a black screen flashes and the game closes.

If I disable Directx12 in options, and go to play. This black screen appears below and does not advance.
02


Complement

If I start the game via wine command line without lutris, the message below appears

WINEPREFIX=’/home/leonardo/Jogos/Shadow_TR’ DISPLAY=:0 wine start /unix ‘/home/leonardo/Jogos/Shadow_TR/drive_c/Program Files (x86)/Shadow Of The Tomb Raider/SOTTR.exe’

04

The game doesn’t need any winetricks to work, so we can rule that out. I know the game works because I installed it ages ago. But I didn’t use directx 12. I think directx 12 on Lutris is older than git. So try to download the latest git and place the DLL’s in the prefix system folders. If you do that you will need to disable “dxvk/vkd3d” in lutris, because you manually replaced the DLL’s. remember to create a backup first.

What is your wine version? I would recommend using wine-tkg for lutris.

When you start the game, right click on it in lutris and say show logs. so we can see what is happening in the background also.

Make sure your also using the correct GPU if it’s intergrated. The command is DRI_PRIME=1 in lutris. I use nvidia gpu so anything to do with AMD gpu is just what i’ve picked up.

1 Like

Have your tried launching directly from Steam? Proton (Steam Play) should work fine. However, a Ryzen 5 APU probably isn’t going to be good enough.