Settlers 3 [GoG] Game Breaking Bugs. (Right-click / Alt-Tab)

Trying to play Settlers 3 from my GoG library.

Bug #1: Right-Click
When I am in a game, and need to use Right-Click drag to move the map, the game acts as if the mouse is in the top left corner of the screen, and drags the map there (and the view window to the bottom right). Clicking on the minimap works fine, however.

Bug #2 Alt-Tab crashes the game.
If you are in-game, and Alt-Tab away (or focus is grabbed by another program for any reason), when you came back to S3, a wine error comes up. When getting the debug info for this issue, for the first time, the text of that error was visible, so I was able to get that. “DirectInput Error DIERR_OTHERAPPHASPRIOoccured at CDirectInputDevice::DIAcquire” (The OK box is not clickable) and the only way to close it is to hit the X and wait for the OS to notice that it has frozen.

Failed Workaround: Virtual Desktop
I tried to put it in Virtual Desktop mode, but that didn’t work at all. None of the game assets showed up in the Virtual Desktop window, only the destop itself. It resized for the opening cinematic, then resized for the game menu, but neither were visible.

Failed Workaround #2: Registry entry.
When creating this issue, Lutris forum pointed out that someone else had Alt-Tab issues forums . lutris . net/t/all-games-crashing-w-alt-tab/10273/5), so I tried this fix: (askubuntu .com/questions/299286/how-to-recover-focus-after-losing-it-while-using-wine/1202472#1202472) but that didn’t change anything. (Sorry, the forum won’t let me put more than 2 links as a new user, so I’ll just reserve those for the logs below)

Lutris -d: Lutris Settlers 3 Console Log -
View Logs: Lutris "View Logs" log -

Virtual Desktop mode:

DirectInput Error:

Sorry, Just realised I hadn’t attached this: (lutris-issue-report.json)