Back to the main site

Set Lutris to use 32 bit wineprefix?

Hi,

I am running Arch Linux and am trying to install applications through lutris. I have tried with the install scripts and with installation yml files. It appears my issue is with Lutris creating a 64 bit wineprefix to store the installation files when the application requires 32 bit. I have not found anything on this and have tried all that I can find that is remotely related.

Application I am trying to install -
Vortex mod manager
ModOrganizer2

I have completely removed wine and Lutris and reinstalled both. I have created 32 bit wine prefixes but it appears Lutris creates new ones before running the installers and there doesn’t seem to be a way to redirect it pre installation to a different wine prefix.

I am running the latest version of Wine-Staging and Lutris. Below is my system information copied from the Lutris preferences.

[System]
OS: Arch Linux rolling n/a
Arch: x86_64
Kernel: 5.8.1-arch1-1
Desktop: Not found
Display Server: tty

[CPU]
Vendor: GenuineIntel
Model: Intel® Core™ i7-6700K CPU @ 4.00GHz
Physical cores: 4
Logical cores: 8

[Memory]
RAM: 15.6 GB
Swap: 0.0 GB

[Graphics]
Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 1060 6GB/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 450.57
OpenGL Core: 4.6.0 NVIDIA 450.57
OpenGL ES: OpenGL ES 3.2 NVIDIA 450.57
Vulkan: Supported

Please let me know if any more information is needed.
Any information or advise is greatly appreciated!

I’m not familiar with those applications but Lutris has a selection for prefix type and its default auto so it figures it out without any help.

However, both are listed as garbage with wine in recent year.
https://appdb.winehq.org/objectManager.php?sClass=application&iId=18866
https://appdb.winehq.org/objectManager.php?sClass=version&iId=36189&iTestingId=100902

So its difficlt to say if you will have success or not. The easiest thing would be to get old versions of the application and of wine that worked but that may or may not be possible as well.

Thanks for the reply,

It’s kinda sad that I didn’t realize winehq lists in ascending order (newest version listed below older) until your post…

That being said, where is that option located in lutris?

What I’m trying to achieve is setting up one of these two programs so I can install and manage mods for fallout 4 without having to do so manually, when I try to install modorganizer it fails at a 32bit dependency. So I’m thinking if I can set it manually to use a 32bit prefix I might be able to get that one installed.

If you go into the game/application config in Lutris its on the game options tab.

You should probably check to see if wine has all required 32 bit packages install through the distro package handler eg apt or dnf. Lutris is a bit of a misdirection as it doesn’t necessarily install all packages and maybe even be missing ones required for 32 bit even though it supposedly ships wine with it. It isn’t reliable. You can alternatively just try installing all distro wine dependencies by installing wine eg apt-get install wine or dnf install wine. Instead of wine-___ or whatever.

If they’re all installed and it still doesn’t then you will need to look into other things.

Thanks I will try that