[self-solved]Lutris times out instead of launching

I can’t get lutris -d to provide output, so here’s the output I DO get.

[sunderkeenin@jerodpc ~]$ lutris
Failed to register: Timeout was reached
[sunderkeenin@jerodpc ~]$ lutris -d
Failed to register: Timeout was reached

Since I couldn’t get debug output from lutris here’s the output from inxi -b.

[sunderkeenin@jerodpc ~]$ inxi -b
System: Host: jerodpc Kernel: 4.15.0-23-generic x86_64 bits: 64 Desktop: i3
Distro: Ubuntu 18.04 LTS
Machine: Device: desktop Mobo: ASUSTeK model: PRIME B250-PLUS v: Rev X.0x serial: N/A
UEFI: American Megatrends v: 1001 date: 12/11/2017
CPU: Quad core Intel Core i5-7500 (-MCP-) speed/max: 800/3800 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480]
Display Server: X.Org 1.19.6 driver: amdgpu Resolution: 1920x1080@144.00hz, 1920x1080@60.00hz
OpenGL: renderer: Radeon RX 580 Series (POLARIS10, DRM 3.23.0, 4.15.0-23-generic, LLVM 7.0.0)
version: 4.5 Mesa 18.2.0-devel - padoka PPA
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives: HDD Total Size: 2174.6GB (14.7% used)
Info: Processes: 244 Uptime: 14:13 Memory: 1867.8/15986.8MB Client: Shell (bash) inxi: 2.3.56

Any idea what’s going on here?

Edit: The issue was an .Xauthority-c file being locked, so I couldn’t even startx. rm -fr ~/.Xauthority-c resolved all of my issues. Not an issue of Lutris itself. Restarting your computer does wonders, including isolating the real problem.

I’m glad you could solve it. I always try to restart my machine to either test if something is still working or to get things to work again. Instead of actually pressing restart, I do recommend powering it off completely and then on back again.

I had some trouble with my graphics card that was solved that way, once.