Segmentation Fault on startup

[ahkana@ahkana-pc ~]$ lutris -d
INFO 2019-06-19 06:53:18,882 [application.do_command_line:225]:Running Lutris
INFO 2019-06-19 06:53:18,883 [startup.check_driver:54]:Using NVIDIA drivers 430.26 for x86_64
INFO 2019-06-19 06:53:18,883 [startup.check_driver:58]:GPU: GeForce GTX 1060 6GB
INFO 2019-06-19 06:53:18,883 [startup.check_driver:75]:GPU: 10DE:1C03 1043:8618 using nvidia drivers
INFO 2019-06-19 06:53:18,905 [startup.check_vulkan:129]:Vulkan is supported
INFO 2019-06-19 06:53:18,905 [dxvk.get_dxvk_versions:21]:Updating DXVK versions
Segmentation fault (core dumped)

I have absolutely no idea what happened as it was working fine the day before…

I have exactly the same problem, AND I use the same GPU.

This is my json produced from lutris --submit-issue:

My problem turned out to be python-pillow-simd. Not sure why but it seems after an update it just didn’t work anymore. I had to remove it and use python-pillow instead.

If this isn’t your issue you can try installing gdb to help backtrace what’s causing it.

When installed try “gdb --args /usr/bin/python3.7 /usr/bin/lutris” (this is what worked for me) in the terminal and then type “r” to run, after that type “bt” to backtrace the issue. (without the quotes)

Well, that worked! Thanks!

1 Like