Running Diablo IV closes


I am running through Lutris. When I tried to run Diablo IV in Battlenet, both would crash. To solve that I had to back the VKD3D version from v2.9 to v2.8. That got the Diablo working, but when I run Diablo, Battlenet itself still closes.

Any guidance you could provide would be much appreciated.

Ubuntu Pastebin Links: Ubuntu Pastebin


Hi! It might sound like a silly question, sorry if it is, but have you checked the Battlenet options? Asking because I had the same behaviour (except I haven’t been able to get DIV to run lol) and it was just because the option “ON GAME LAUNCH: Exit completely” was ticked by default on install.

I was surprised because I had no idea it even existed.


This solved it! I had no idea this option existed either. This was my second time installing through Lutris. The first time that option wasn’t selected by default. I originally had some issues trying to move and run the game from another drive/partition so when I ran a clean install I figured I’d messed something up. Thanks for the tip!

There is a good reason why this was disabled in the script - agent.exe and running in the background are polling for updates and other items. Agent.exe in particular has a bad tendency to die randomly, and when it does it causes whatever game you are playing to crash. Was a big issue for OW2 players where the game dies mid fight. So it is highly recommended on Linux to keep this setting as is and if you do change it and experience in game crashes, start here first in debugging what is going wrong.

Thank you for the info, will do!

Ha! I’m really glad i saw this thread. I experienced the same thing after doing a reinstall of battle . net and couldn’t figure out what was wrong.

Here’s the interesting part. I just ran battle . net to go check for that box, and when i ran it a dialag came up asking me if i wanted to keep battle . net running in the background - so it could check for updates. There are two choices

  • minimize to system tray
  • exit application

I guess I should stick with “Exit application” !