Runner PCSXR seems to be not working on Fedora 24

Hello ,

I’m new to lutris, and I’ve just tried to play Alundra on PCSXR, here is what the error log says :

/home/<USER>/.local/share/lutris/runners/pcsxr/bin/pcsxr: /home/<USER>/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu/ no version information available (required by /lib64/

/home/<USER>/.local/share/lutris/runners/pcsxr/bin/pcsxr: /home/<USER>/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu/ no version information available (required by /lib64/

/home/<USER>/.local/share/lutris/runners/pcsxr/bin/pcsxr: symbol lookup error: /lib64/ undefined symbol: atk_range_free

I’ve also tried with another game (Grandia), same error :worried:

It seems to be related to Lutris, since I can successfully load the games in pcsxr manually.


PCSXR as had problems for a long time and is now deprecated in Lutris. You can use Libretro instead where we provide 3 different options for Playstation emulation:

  • PCSX Rearmed, were you might run games without a BIOS
  • Mednafen PSX, were you need to provide a BIOS
  • Mednafen PSX HW, same thing but with more rendering options, still in alpha and a bit glitchy

If you want to use PCSXR you still can by setting a custom location for the executable and disabling the Lutris runtime but be aware that we will completely remove it in a future version and switch the games to PCSX Rearmed.

Ah thanks,

I’ll make another Alundra Installer then.

As for libreretro, I just don’t get how to use it via the lutris client, I installed it but can’t run it, when i try to launch a game, it just say "Preparing to launch " and seems to be blocked in an infinite loop.

When i try to launch retroarch via shell it throws an error

./retroarch: error while loading shared libraries: cannot open shared object file: No such file or directory

So I installed libCg, but at no moment has lutris told me about this error nor asked me about installing libCg for dependency…

retroarch now launch but with another error and ugly graphics
Failed to open /home/user/.config/retroarch/assets/xmb/monochrome/font.ttf: No such file or directory

That’s the part I’d like to debug, do you see any messages if you launch Lutris from a command line and run a retroarch game?

That’s because libCg is included in the Lutris runtime so it will run fine from within Lutris itself. If you want to use it outside of Lutris, then yes, you have to manage the dependencies yourself.

Ok, that’s something that needs to be fixed and which we have overlooked. The retroarch config file does not point to the location of the assets. Until we ship a fix you can either copy ~/.local/share/lutris/runners/retroarch/assets to ~/.retroarch/assets or point assets_directory to ~/.local/share/lutris/runners/retroarch/assets in ~/.config/retroarch/retroarch.cfg

Here is the error message
Traceback (most recent call last): File "/usr/lib/python3.5/site-packages/lutris/gui/", line 545, in on_game_run File "/usr/lib/python3.5/site-packages/lutris/", line 161, in play self.do_play(True) File "/usr/lib/python3.5/site-packages/lutris/", line 169, in do_play gameplay_info = File "/usr/lib/python3.5/site-packages/lutris/runners/", line 102, in play core = self.game_config['core'] KeyError: 'core'

OK I changed assets_directory, it works well now.
Thank you.

Oh, I see!

You forgot to set a core to the game, I recommend you start with PCSX Rearmed then switch to Mednafen PSX if you want to set up the BIOS files manually.

I’ll fix the runner code to display a proper error message in those cases.

I have improved the retroarch runner to fix the assets path problem and there are now error messages displayed if no core is specified or the game rom isn’t found.

Those changes will available in the next version planned for the 25th.