Back to the main site

Runner missing 2 dll's: msmpeg2vdec.dll & msvproc.dll

Hi, Everyone. I’m a new linux user on the latest Garuda gaming distro.

System specs here: Ubuntu Pastebin

I only play World of Warcraft (retail) and have followed all the steps before & during a fresh lutris install, ensuring my drivers are vulkan drivers are installed and up to date, and using the -d3d11 startup flag in battlenet to force WoW to use directx11.

The lutris logs tell me I’m missing 2 dll’s. I’ve sought to add them via runner configuration but I don’t see them explicitly listed in the drop-down of addable libraries.

Log here: Ubuntu Pastebin

I haven’t changed any of the defaults for lutris, wine, or winetricks because as a noob, I don’t really understand most of what I’m looking at. A little hand-holding as I learn my way around will be greatly appreciated, especially if I can solve the problem as a result.

This issue is a several-times-per-day occurrence, though it isn’t an everytime thing. It happens mostly when I’m logging into an existing character. The progress bar advances about 2/3 the way and then freezes for about 5 seconds, after which it pops up an error message saying a memory location couldn’t be read. It’s a different location each time, but the one thing that’s consistent is the 2/3 complete progress bar freezing a few seconds.

I have had it happen also in game, just doing nothing of any particular significance. Once I was turning my character to follow a path, for example. There’s no rhyme or reason that I’ve noticed other than the progress bar.

Anyway, I hope this is enough information to make a useful first-step toward solving the problem. Thanks in advance for all helpful replies!

1 Like

Lines 5-9 from my log pastebin, above:

fsync: up and running.
[0901/144434.085:ERROR:network_change_notifier_win.cc(142)] WSALookupServiceBegin failed with: 0
[0901/144434.419:ERROR:dxva_video_decode_accelerator_win.cc(1397)] DXVAVDA fatal error: could not LoadLibrary: msmpeg2vdec.dll: Module not found. (0x7E)
[0901/144434.420:ERROR:dxva_video_decode_accelerator_win.cc(1405)] DXVAVDA fatal error: could not LoadLibrary: msvproc.dll: Module not found. (0x7E)
[0901/144434.560:ERROR:dxva_video_decode_accelerator_win.cc(1320)] DXVAVDA fatal error: Could not load msmpeg2vdec.dll: Module not found. (0x7E)

Can someone tell me whether this is, or isn’t, an issue that ought to be solved within the lutris runtime? If it is, I don’t understand why no one has replied so far. But, if it isn’t, then please kindly tell me where the issue ought to be reported in order to get the attention it deserves.

Thank you.

Sorry I did not see that your post was about WoW.
The missing files are not the problem with it crashing during loading your character - If you locate your WoW retail folder, there will be a folder called Errors there and in that folder will be a bunch of text and dump files. Open the most recent txt file and copy over the first 20 lines in it. This will tell you which file is missing. Also, you really don’t need the -d3d11 flag. In Lurtis, enable the DXVK and VKD3D options.

I would wager that it is sapi.dll missing. To add this, you will need to go into WineTricks (from the arrow next to the wine glass icon when you have selected your game in Lutris) and select default prefix - install a Windows DLL - and locate sapi in the list. If it doesn’t have a check mark, check it and select Ok to install the missing dll. This should fix the character load/swap error in WoW.

EDIT: I haven’t tried the default Lutris runner in ages - I would suggest looking for a different runner such as a GloriousEggroll runner (link). The simplest method to add this to Lutris is using ProtonUp-qt (available as an appimage - just need to set the executable flag after download). Some of these runners have tweaks to improve compatibility with WoW from experience.

1 Like

Hi, Jhu. Thanks for your reply.

Here are the uppermost lines from the most recent WoW error file:

World of Warcraft: Retail Build (build 45114)

Exe: C:\Program Files (x86)\World of Warcraft_retail_\Wow.exe
Command: “C:/Program Files (x86)/World of Warcraft/retail/WoW.exe” -launcherlogin -d3d11 -uid wow
Time: Sep 4, 2022 9:31:32.643 PM

This application has encountered a critical error:

ERROR #132 (0x85100084) Fatal exception!

Program: C:\Program Files (x86)\World of Warcraft_retail_\Wow.exe
ProcessID: 1436
ThreadID: 1440
Exception: ACCESS_VIOLATION

The instruction at “0x000000017002e34f” referenced memory at “0x0000000000000bf8”.
The memory could not be “read”.

<Exception.IssueType> Exception
Crash
Exception.Summary:
ACCESS_VIOLATION
(DBG-OPTIONS DBG-ADDR<0000000222127838>(“sapi.dll”) ← DBG-ADDR<00000001421335af>(“Wow.exe”) ← DBG-ADDR<0000000142119008>(“Wow.exe”) DBG-OPTIONS<>)
The instruction at “0x000000017002e34f” referenced memory at “0x0000000000000bf8”.
The memory could not be “read”.

It lists the sapi dll file, just as you suspected. On my system, the DLL’s don’t have checkmarks in the list to add them into winetricks. It’s just a list, where you highlight the DLL you wish to add and press “OK”. I followed your instructions and it appears to have worked. I got a popup warning me about installing 32-bit verbs into 64-bit prefixes, but nothing like an error message suggesting that it didn’t do as I asked.

I’ll test this out tomorrow as it’s just past 2am where I am and I’m about to go to bed.

To your point about the Glorious Eggroll runner, I’ll work on that tomorrow and give it a try. I think I remember reading elsewhere that the proton runners were supposed to be specific to games launched through Steam and not via Lutris – is that correct or no?

In any case, along that line, I also added battlenet to Steam and was able to run it that way, too. It also crashed on character loading, but only the first time I launched it. Since that first time, I don’t recall it erroring-out on me again; I could be wrong but I don’t recall more than one error case.

Thanks again for your reply. We may not need this after all but just in case, here are the updated spec’s from my system. It’s pretty long, I know. I was going to trim everything that seemed not relevant, but with my luck I’d trim something you’d otherwise find useful so here’s the pastebin.

I post an update after I’ve had some time in game with the various changes. Fingers crossed! :slight_smile:

The link I gave is for the non-proton GE builds. As for running through Steam, that is how I run WoW with the latest GE Proton build. I also run Epic Games Store through there as well. Just find it more convenient to use it as I also have some Steam native titles. Only important thing about your config to note is the GPU and Mesa version, I use this command to get that info:

inxi -GSC -xx

Okay, here’s my experience so far:

If I select to ‘use system winetricks’, and i disable both esync and fsync, my experience from login to game play is rock-solid stable. This is the case in lutris with 3 distinct prefixes: default lutris, wine staging, and proton ge.

Some of my characters are in a guild but most are not. What I’ve noticed in this regard is that when I play via steam, whether the default or the proton prefix, my guild button in the WoW toolbar isn’t clickable. When I hover my mouse over that button, the tooltip has red letters with words to the effect of ‘feature not available’. This was also true when running via lutris IF I didn’t have ‘use system winetricks’ toggled. Since I don’t have this option to explore in steam, I’m assuming that this is an issue with whatever winetricks may be built into default lutris and default steam?

Anyway, my final observation is that regardless whether I run via steam or lutris, and regardless the prefix, every time I start battlenet, it goes through the motions of an update. It also goes through the motions of updating if I log out of Shadowlands and into Wrath/Classic or vice-versa. I say ‘goes through the motions’ because it takes a few seconds in the ‘initializing’ phase, and then in the ‘reclaiming disk space’ phase, but as far as I can tell, it doesn’t actually download a manifest or apply updates. This isn’t really related to my original question but it seems worth mentioning here in case there’s something that can be done to stop this behavior from happening. When I was running under windows just a couple months ago, this never happened except on patch days (for WoW, that’s every Tuesday). So, I’m guessing there’s something that happens under windows that isn’t happening under wine. Again, this is a bit of a tangent but I’ll mention it just in case you may have some idea off the top of your head.

So, that’s my update. If the winetricks, esync/fsync are at all helpful clues for anyone going forward, then this update will have served its purpose. Thank you again for all your help, leading me to this point!

Since my last post, I’ve played quite a lot and not a single lockup during login or boot during gameplay.

The battle.net update is an issue that you can find on here and reddit. I have always just ignored it. As long as the game is running without stutters, crashes and a good FPS, I am happy. Glad it is working for you!

From a practical point of view, yes, it’s nice to be able to play the game.

In principle, though, I’m curious why the battle net update issue continues to be an issue. Is there no one who’s interested in solving the problem at its point of origin?

For example, if selecting to use the system’s winetricks solves a problem, why doesn’t that become an issue to solve, or at least to document formally at the point of origin? And, who would be the person or group responsible for such a solution? Would it be the winetricks author? The wine author? The lutris author? Some combination?

Working around a problem is a nice-to-do thing in an instant, but the work-around shouldn’t be ‘the final answer’. It’s sort of like getting a headache, and taking a pill to relieve the pain, and then saying, “well, no one is interested in finding out why you get these headaches but as long as you can take a pill and feel better, that’s ‘good enough’.” It’s nice to be able to take a pill and get some immediate relief, but it would be better if one could then diagnose the source of the headache and address the issue at its source once and for all.

Where, exactly, should I begin looking to volunteer my time to help track down the source of the battle net update issue? Lutrus? Wine? Winetricks? Other?

Install the Lutris-5.21-x86_64 runner. I searched around last night and this was the last runner that did not have issues with the update on Battle.net. I don’t use it because for some reason i could never get dx12 working.

Thank you. I’ll give that a try.

To my point about ‘solution vs work-around’, though… what does a diff show between the runner you recommended to me and the next release, where the bnet update became a problem? Please remember, i’m just an outsider looking in. I don’t know what’s what, which is why I’m here asking questions.

I don’t have dx12 enabled on my setup. I read elsewhere that there are some map areas in WoW where 12 is broken. That may be a WoW problem rather than a wine problem for all I know. But, for me, I’m unaware of anything ‘missing’ in my game experience for staying with 11 vs 12. That’s why, as you mentioned a few replies earlier, I use the command line argument to specify dx11 specifically.

Similarly, I restrict my framerate to 60, even though it defaults to 100 and runs flawlessly at that speed. I don’t notice anything negative by running at 60fps, and my display adapter seems to run noticeably cooler for limiting to 60.

But, I digress…

I’ll try the older runner and see what happens. Meanwhile, I’m still not clear on which project is best understood as the source of the update glitch. Is it lutris, wine, winetricks, or some combination, or some other package where this ‘problem’ exists and began?

Scratch my previous reply. Try Wine-Staging 17. It has a delay after the battle.net launcher window displays but does not try and update on load. This would imply that a patch being added to the other non-core (GE, Lutris, TKG) runners is introducing the updating error and why I could not find it referenced at winehq.

7-days ago I mentioned, as an aside to my original question, that I was having problems with the battlenet client continuously updating. Since your last reply to me about trying wine-staging 17, my experience with the wonky update behavior continued.

Thinking that perhaps my difficulties were related to me running on garuda linux (their ‘gaming’ distro; “soaring” I think?), I looked around at the distros that other people were using to play wow. Since I’m relatively new to linux, and I have nothing of a personal nature on my laptop (it’s all on the cloud), I decided to scrap my garuda install and start fresh with manjaro.

So, for the past 6-days or so, I’ve been fighting with the installation of battlenet. I couldn’t get it to install no matter what I did. And, when I would somehow get lucky and get it to install, the client would never install the game. I now see over the past couple days that my experience wasn’t unique to me after all. Several people in other threads here have reported being unable to update, and then when they also tried to install from the beginning, they also were unable to do so – just like me.

In some ways, I feel a bit relieved to realize that my problems weren’t primarily due to me being a clueless noob on linux. In other ways, I feel frustrated (not with you, just my experience in general) that, having taken the plunge into linux to ditch windows once and for all, I now found myself unable to play wow and feeling rather stupid, as if it was my fault as a new linux user.

Given the several threads that have appeared about the update bug, I realize now that the issue wasn’t specific to the linux distro I’m running. Last night, I downloaded garuda again, but with the xfce option rather than kde (because I had read somewhere in my online searching that blizzard sometimes appears to run into a bug under kde, but that no one has yet identified clearly enough to submit a bug report about). I’ll stick with this distro for now and see how it goes (unless you or someone else replies to tell me this isn’t a good idea?)

I just now downloaded the previous agent exe and am going to try to get a fresh battlenet client install to complete so that I can swap the new, buggy agent exe with the older, still-working agent exe.

Will update this thread again after I’ve made this attempt and, hopefully, succeeded in getting battlenet and wow installed and working. Just want to say “thank you” again for all your time to help me work through all this. Ok, going to give this a shot. Fingers crossed… :slight_smile: