Back to the main site

Run EXE inside wine prefix

I have installed Evil Genius game using lutris (lutris-4.16-x84_64 runner).

When i try to launch the game in standard way (with double click or with “Play” button, the game crushes with returncode 5. Logs says that the problem is with the missing libncurses.so.5 library. This is a kind of a wine bug, as i understand.
BUT!!! If I run the game exe using “Run EXE inside wine prefix” in lutris right panel menu, the game work just perfect, without any error or crushing!

OK. In that case I can make my own launch script and use it as an icon on my desktop, I thought.
I tried the command
env WINEPREFIX=/home/DataDisk/Lutris_Games/EvilGenius_Prefix/ /home/stanislav/.local/share/lutris/runners/wine/lutris-4.16-x86_64/bin/wine /home/DataDisk/Lutris_Games/EvilGenius_Prefix/drive_c/Games/Evil\ Genius/ReleaseExe/EvilGeniusExeStub-Release.exe

…and i obtained the same error with missing libncurses.so.5

And here is my question. How is the command that Lutris forms when you use the “Run EXE inside wine prefix” menu looks like? And what are the differences with my launch script. I think Lutris adds some additional arguments but what are they?

P.S. If you want to suggest to install the ncurses library. Well, I have tried. Installation of ncurses5-compat-libs did not help, as well as copying or linking the existing libs of ncurses v6.

Weird. :thinking:

When you start Lutris from the console and start the game, do you see the command which is issued then?

For applications in the library Lutris use the following command:

lutris lutris:rungameid/

But this works for installed programs in the library. the magic behind this command is hidden)

Could be be the Steam (Windows version) exe which generates the error? Does that run when you start it from the WINE prefix?

Lutris starts Steam, Steam starts the game by using the game id. Game runs fine without Steam. That’s my deduction for now…

It is not the Steam version. The game was installed from local source using lutris-4.16-x84_64 runner.
If i use wine 4.18 runner, the behavior is same, but the game crushes with the returncode 53 instead of 5.

Still don’t know why it runs when directly started.

You could enable debugging info in Lutris as described in this thread: