RTCW - console, arguments aso

Hi there,

I hope I am in the right topic category, because it is my first post. I have a few questions, special and general. In “Return to Castle Wolfenstein” there is a possibility to open a console by any key. I could not find the right one, although I tried so many possibilities. Perhaps anyone can help me, which keys to press for console.
I used the installer for native & steam (64bit) version. It says native, but works with an .exe, so is this possible? I ask, because for the windows version you can set +set sv_cheats 1 to get cheats after the link for the executable (yes, I do cheats!). In the Lutris game configs you can put arguments. So can I put the above in there or is this just for commands given by Lutris (screen size etc.)?

Well, according to this guide, you need to add set sv_cheats 1 to the executable arguments list (I’m guessing the + part is specific to Steam and means “append this to execution command”, as usually when I’ve used the Launch Options, I provided the whole string with the original execution command marked as %command%).

As for Lutris “Arguments” config field, yes, they’re added to the game execution command, same way as if you added them by hand in command line. Steam, however, doesn’t pass arguments received this way to the game (I think; haven’t actually tried that, come to think of it).

Er… Are you talking about native Steam? If that’s the case it’s probably using Proton (called “Steam Play” in the client) to run it, which is basically a custom version of Wine; you can (and should) treat it as a regular Steam game, which also means you need to use “Set launch options…” dialog to add command line arguments, rather than Lutris (as I’m pretty sure it’s the only option for games run by Steam client).

OK, this helps a bit further. How the argument works best, I can then try out myself. The “+” is on other cheat pages always within, so it is not for Steam only. My biggest problem is still which key opens the console. Neither ^ nor ’ or ~ works.
On the Lutris page it says “Linux Native + Steam (64bit) version”, so I thought this version is LINUX native (a read about a publication in 2002), but the .exe is surely Windoofs. But anyway, I try to find out more about this Proton client, because I am Newbie at Steam.
EDIT: I found out, that the games configs and saves are stored in /.wolf/main. So there can be found the wolfconfig.cfg. Opening that one tells me, that ~ or ` should do the toggleconsole.
EDIT 2: I changed BOTH toggleconsole to “h” and “j” and now for some not understandable reason it works!

I’ve checked that script just now
It uses game data from Steam install but runs a downloaded executable port. The executable is native 64-bit Linux binary (apparently compiled from official game sources… or maybe from their fork) but for some weird reason has an .exe extension :smiley:
So, neither Steam nor Proton/Wine are involved in running the game, only in install.

Might be a bug in the port. You can poke around with it if you feel like contributing/fixing it properly.
…Or you could just leave it at that, I guess. Though I’m pretty sure you only needed to change one binding to a working key (or you could even add one instead of replacing an existing one).

It turned out, that all just works with US keyboard layout. I guess, if I had it changed earlier, the problem with ^ or ~ would not have been happened.
I won’t poke around, I do have too less knowledge. I just wanted it all written down for anyone who will get the same problem in future. Thx for your help, LeX.
Case closed, I hope.

…Yeah, non-US keyboard layouts can give problems with applications not specifically made with support for other locales in mind. It’s one of the reasons I stick to running my system in English despite not being a native speaker (another one is that translations, at least those I’ve seen, usually suck :smiley:)