Back to the main site

Rockstar Launcher won't download GTA V [Solved]

so thanks to the amazing work of everybody the new rockstar launcher installs and runs fine. But then when i try to download GTA V (i own the Rockstar version, no steam download) it downloads about 1Gb and then it keeps using all my internet but the progress isn’t going further than 1GB. i checked my network activity and it’s really using the amount of internet the download speed tells me. it’s not a broken progress bar since donwload speed works fine and keeping it running for more then 7 hours did nothing (the download should have been completed between 4 and 5 hours according to both my calculation and the download estimationg of the launcher)

the only progess i made is that when i pause the download and resume it about 100mb is kept and it progresses to about 1.1GB but this doesn’t work because at about 1.8GB only 400-500mb survive the stopping and resuming of the download no mather how often i restopp and reresume it.

any fix would be fine i could probably fix it by downloading GTA v “Somewhere else” and then just run the file integrity check of the launcher on it but i really want to avoid having to download it from “somewhere else” or trying to copy it from a windows pc.

Hi mucan,

I have exactly the same issue!!! I see the speed moving but the size of the installation gets stuck around 1GB, if I try to re-download it starts from beginning 100mb-300mb. Glad someone is having the same problem as me, I was going crazy. I will provide my log, maybe someone will be able to help us out.

https://paste.ubuntu.com/p/9dsBcqKY4s/

Using the last lutris script for rockstar edition (not steam) + DXVK.

the old social club launcher for GTA V used to have some problems starting or towards the end of the download where some stopping and resuming often fixed it for me but i think this is just some rockstar launcher or rockstar download server issue but maybe someone can find something in your log

Same problem here. I committed the horrible crime to install a windows vm just to download the game and rsynced it to the wine prefix created by Lutris. That worked halfways. It doesn’t try to download anything but now I’m stuck at “Loading”. Still in the launcher screen

yeah i did the same and after installing the prefix new i got the launcher to accept the GTA V game data but the launcher won’t launch the game so it’s not even the download it’s just the launcher just straight up doesn’t work which is a shame… i also tried some exes and fixes that should make the game launch without the launcher but nothing works you have to go through the not working launcher… really a shame

Has anyone figured out the cause, or a fix for this? Side-loading the games via Windows isn’t a viable option for me.

Worked for me too.

to everyone who posted here there is a new lutris runner which uses lutris-nofshack 4.18 and the download and the game are fixed again

1 Like