Back to the main site

Retail WoW stuck on intializing, but classic wow works

Ive been trying to install retail wow for a couple weeks now and i havent made much progress, the install is always stuck on initializing and crashes if it stays like that for a couple minutes.

In the logs it says im missing some dll’s(msmpeg2vdec.dll & msvproc.dll) but i can not find them in the winetricks windows dll installer list.

I have also tried updating vulkan drivers but that didnt do anything, so at this point i feel pretty lost cause i havent found anyone with the same problem.

Any ideas or tips?

This also happens sometimes on Win 10 - click on the pause and if you have another game, switch to it and update then return to WoW and press start, eventually it will finish. Check your runner - if you are on Wine-GE 7.33/4 then it seems to be a feature, try switching to Wine-staging or Caffe (newest one you can find). Don’t use this if you plan to run OW2, setup a separate entry in Lutris for OW2 with the Wine-GE7.34 runner.

1 Like

Thank you for your reply, i tried pausing the initializing and install classic, and then resuming the retail download but it did nothing. I am using the system 7.21 wine version but the caffe 7.18 doesn’t even start battle.net so I am unsure what to do next.

Use the discord link on the Lutris.net home page - maybe someone over there can help