[resolved] Frostpunk - startup error

I had no problems to install Frostpunk the first time, this was a month ago or so.
Now however, I bought a new hard disk and re-installed Frostpunk on my new disk with the official script gog w / DXVK from lutris. The game launches, but it does not start the game.
This is the error msg:

Frostpunk err1

So I used rsync to copy over my previous installation of Frostpunk. My previous installation had no errors or issues whatsoever, it worked perfectly out of the box.
Surprise, even this time I get an error dialog after starting FP, but with more choices.


awkwardly, the default button is Cancel (1st button), then Repeat (2nd button) and finally a “Ignore” (3rd button) option. I’ve to click the “Ignore” button twice to get to the game. The close button (green x) just quits the game. Not sure what the game"s performance is, did not try yet.

What is missing ?
Do I need to download some particular file of ProtonPlus ?

I forgot, here the Wine Protocol

Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
Monitored process exited.
Initial process has exited (return code: 2304)
Exit with return code 2304

the wine protocol complains about
RLIMIT_NICE is <= 20, unable to use setpriority safely
I found this:

but the problem is not Proton - it’s clearly DXVK related, if DXVK (starter options) is off, Frostpunk starts normally but with visual errors (almost pitch black screen and floating textures all over the screen).

Also, the first error dialog complains about a winevulkan.dll lib inside system32 ? why, if Frostpunk is a 64-bit game?
And renaming C:\windows\system32\winevulkan.dll is a bad idea, the game seems to need that dynamic lib.

check what version of lutris you are running - if it is 0.5.16, then go to preferences → global option → enable Advanced at the top and find vulkan ICD loader. You need to change this to match your gpu and NOT say unspecified.
Also the error could be 32 bit dependencies missing - these links are GUIDES - don’t just copy paste, read what they are going to do and check if it matches your needs. If you are on 21.3 Mint, ignore the warning:
link 1
link 2

Current OS: Linux Mint Cinnamon edge, v21.3
Game: Frostpunk goty
Installation: Gog scripts from Lutris.app and Lutris website

thanks for your answer.

under advanced settings, I changed DXVK to v2.2 and that one worked without issues. Then I also tried v2.3. Both versions worked perfectly.
Lutris selects new versions by default and DXVK v2.3.1 must be a regression.

Thanks a lot!

What gpu and drivers- unless you are on an extremely old gpu, 2.2 is a regression and you did not confirm what version of lutris - Mint has an old version in repo’s

Lutris: 0.5.17
Gpu: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
Window System: X11

0.5.17 is good - the issue needing 2.2 or 2.3 is troubling with this - but a workaround runs- just watch for the next update to DXVK which may break it again