Back to the main site

Recen't WINE runners don't work

I’m having issues with the recent wine runners - they don’t start at all on my end.
I’m using Lutris on OpenSUSE Leap 15.1.
Any ideas what might be going wrong? I’d love to fix it as I see there’s a vkchildwindow patched version that in theory could allow me to start Affinity software.

edit: copied the runtime to POL directory and when starting I’ve noticed this:

/lib64/libm.so.6: version `GLIBC_2.27’ not found

so… it looks like recent Lutris WINE builds use newer glibc so I can’t run those :frowning: (btw - is there a reason for that? why older and thus more compatible versions are not used?). Is there a place I could download sources for those patched wine versions and try to compile them myself?

There’s a reason literally every single guide to gaming on linux you see lets you know that it’s pretty much a requirement to use either a rolling release distro or be able to manually update all the libraries and stuff you need in order to have the best chance at running the most games. OpenSUSE Leap is objectively not one of those distros. There’s also a reason you literally never see OpenSUSE Leap on any list of distros most suited for gaming.

On a similar note, your argument that older versions of certain libraries/compilers/etc should be supported because being older means their more compatible is a fallacy. The vast majority of gaming solutions on linux require the most up-to-date drivers, which in turn will require the most up-to-date libraries and compilers, which means that older objectively means less compatible, not more. Look at the protondb breakdown of users by distro. Rolling releases take up 40 percent of the entire number of users, and that’s if you don’t include Fedora. The rest are Ubuntu and it’s derivatives which have easy methods for adding ppas to get more up-to-date software than is available in the repos.

TL;DR if you want to game on linux, OpenSUSE Leap is literally one of the worst distributions for it. Switch to Tumbleweed, or another distro, at least for gaming.

I installed OpenSUSE Leap today and discovered that it uses GLIBC 2.6.
Most of the Lutris runners need GLIBC 2.7 because they are compiled on Ubuntu 18.04.
Then I installed OpenSUSE Tumbleweed, this distribution uses a more recent GLIBC 2.7. I tested some games and they worked as expected.

@gardotd426 : well, but on Leap you get up to date drivers - it is only more careful when updating core components like glibc.
As I use my pc mostly for work that’s why rolling release distro is not even a consideration. Still I like to game from time to time :wink: .
I’d get using newer glibc if the new stuff added simply wouldn’t compile under older glibc. But the thing is it does. It would be awesome if the packages have been compiled against as old glibc as possible for the obvious compatibility reasons.

This annoys me too, I am still on the officially supported “Ubuntu 16.04 LTS” mainly because if I ‘upgrade’ I lose a program and all its video filters, as it is not in the 18.04 LTS repository, and most likely can not get it installed any more.

But both Lutris and ‘Video download helper’ in all their wisdom have decided to start using GLIBC 2.27 , making sure stuff doesn’t work any more.

It’s like saying we don’t care that there are fully supported operating systems out there, we are going to force you to use a newer OS because we can’t be bothered to support any other OS then our favorite one, regardless if that means you will lose functionality in other ways.

I guess the only way is to start reserving X amount of hundreds of gigs in harddisk space and install a separate OS specifically for Lutris, to make sure you can use it when ever they decide to ‘upgrade’ stuff on a whim.