RDR2 launches in lutris but not from the gaming mode (Steam Deck)


I installed RDR2 from the Rockstar Games launcher with lutris on my Steam Deck, with the use of the available script on lutris.net. I added it to Steam’s non Steam apps.

The game launches without an issue if I launch it from Steam when in the desktop mode. But when I switch to gaming mode it display the black page with the rotating steam logo, and sticks there for ever. It doesn’t even trigger the rockstar games launcher.

I tried to change the runner to experimental on the lutris side, it didn’t work better. I tried to let it to the current default on the lutris side (8.7.1) but it didn’t work better. I set it back to the default on the lutris side, and changed it to experimental, and many other versions of proton on the steam config but it didn’t work better (as expected I guess).

I also tried pointing the non steam app to the launcher exe instead of “env” and “./”, and to the game exe, setting a STEAM_COMPAT_DATA_PATH pointing to the related compatdata folder (I had to temporarily set the non steam app to use the compatibility mode for that, which doesn’t seem to make sense to me).

I also reinstalled the launcher (which is actually in no use here, I guess, since the lutris script actually install the launcher in the rdr2 installation folder), and the game, with no luck.

I tried enabling the “LOG_PROTON=1” option in the arguments of the game config but it doesn’t create the expected log. For most tests, I did not add “%command%” onto that line because there’s already some command about the lutris id etc there, and I assumed it means there should not be any use of “%command%” then. Anyways, I tried adding %command% for some tests, also to delete whatever was set in the arguments and only type “LOG_PROTON=1 %command%” but it didn’t even attempt to launch the game when I did so.

I read most of the .log files present in the folders related to lutris, rockstar and rdr2 i could find but did not spot anything but some references to the launcher to not to find nvidia related stuff:

[ERROR:2023-06-05 13:30:44,039:nvidia]: Unable to load libGLX_nvidia.so.0

[WARNING:2023-06-05 13:30:44,039:nvidia]: Unable to locate libGLX_nvidia

I don’t see how it could be related since nvidia shall not be involved + the lutris script disables nvapis, force vulcan-1 and set amd_ags_x64"="builtin,native, which I confirmed by looking at wine’s registry. I found many reddit threads talking about manually setting these, but in this case it’s already managed by the script (probably why it works in the desktop mode I guess).

I read dozens of posts here, on reddit and on the internet in general with no luck. I suppose that the next step would be to understand how to properly enable the proton logs for the app. But I don’t really understand how the argument section works I guess…

Thanks in advance.