Back to the main site

RDR2 Epic Games version not working

Hello,

I’m trying to install epic games version of rdr2 on linux mint.

Started initial process 25218 from /usr/bin/gnome-terminal -e /home/mihai/.cache/lutris/run_in_term.sh
Start monitoring process.
/usr/bin/gnome-terminal.real: symbol lookup error: /lib/x86_64-linux-gnu/libatk-bridge-2.0.so.0: undefined symbol: atk_component_scroll_to_point
Monitored process exited.
Initial process has exited (return code: 32512)
All processes have quit
Exit with return code 32512

This is the error i’m getting in lutris. Stops there.

Suggestions?

That may not be a lutris problem, it could be a distro dependency problem if your packages are out of sync (incorrect versions of the ATK libraries for your gnome-terminal program… I think debian/ubuntu package libatk-bridge separately). Things like this can be caused by installing packages piecemeal, without updating package databases.

It’s been a long time for me, is apt still cool in Linux mint?

sudo apt update
sudo apt upgrade

The first step updates the package database. The second checks for updates, does dependency/conflict resolution and presents a list of packages it’s going to upgrade.

It could also be something setting library paths and loading other libraries in the GTK stack that are incorrect. You can try enabling “disable lutris runtime” in the options of the game before starting the install.

did update and upgrade recently so it is up to date.

disabled lutris runtime.

same error.

Well, what is a fact here is that your gnome-terminal is broken, because of the libatk-bridge that it’s getting in whatever context it is running in.

Is any sort of container involved here, like a flatpak? As the dynamic linker is referencing it, /lib/x86_64-linux-gnu in that context might not be /usr/lib/x86_64-linux-gnu on your system (/lib would be a symlink in the “usrmerge” scheme)

If you have the correct library stack on your system, then I don’t know what’s going on there.

Can you actually run gnome-terminal normally? (like from a menu or desktop shortcut)

how can i see?

yes

OK, so your library stack on your system is good, there is some runtime, somewhere that is overriding and loading wrong libraries when your gnome-terminal is invoked.

As for how to check whether or not flatpak is involved, I don’t know what packages you install, but you would know how you installed Lutris on your Linux Mint for starters. I presume if installed using apt, it would install lutris normally.

I’m on a vastly different system than you are, I haven’t seen a *buntu environment in probably 2 years, nor Linux Mint itself, and I can’t guess.

I should think disabling the lutris runtime would take care of that, but if running the install script for the Epic Games Launcher, that might be chicken before egg if changing it in the existing prefix if it’s already been generated from a previous attempt. The lutris runtime can also be disabled in global options.

I can think of a workaround though, use a different terminal. In the settings of your desktop environment, change your default terminal application to xterm or something.

Look up how to do that for your desktop environment and distro. (e.g. Ubuntu/Gnome) if it’s not readily apparent. (Gnome doesn’t like people changing things and often doesn’t provide such settings in the UI… might have to set an alternative, or even create a symlink). I’m finding different answers for that, which is why I’m saying to look up specific info of appropriate age.

I installed lutris normally, no flatpak involved. I could try an uninstall restart and reinstall.