Qt.qpa.plugin: Could not find the Qt platform plugin "windows" in ""

Hi there! About 3-hours ago I was able to run World of Warcraft without issue. A few minutes ago… the game won’t launch (although lutris itself does)

I’ve included a pastebin link of my lutris-d output.

I’m new to linux and lutris but with a little guidance, I’m happy to do whatever needs to be done to resolve this.


Thanks in advance!

1 Like

Same issue. Until it is resolved, set Game Options → Executable to path for WoW.exe to launch WoW directly, without battle.net client.

1 Like

That worked – thank you!

I’ve been reading online in search of answers but nothing seems relevant to my scenario, which is just using the software to run a game. There are mentions of mathplotlib, and compiling GUI’s, etc., but nothing that seems relevant to a user getting that error.

I’m not even sure this is a lutris error at this point. It seems like it could be a python issue… or a wine issue… or even a qt issue? I haven’t a clue.

In any case, thanks again for your reply. Here’s hoping it gets fixed soon because I don’t want to fall behind on patch updates to WoW.

Since it happened for both of us at the same time, it is likely a bug with a recent battle net client update. Need confirmations from more people.

I found a reddit thread from 4-months ago about this exact problem, along with a solution that seemed to work for those who tried it. I reset my config to point to battle (dot) net (dot) exe and the previous error arose.

I then followed the reddit advice and it works. The only difference between the adivice (pasted below) and my situation are the numerals following “net”. On my system, I have 13960 and 14017. I went into the 14017 tree and then followed the reddit advice:

You have to cd first on this location:

“Program Files (x86)/Battle.net/Battle.net.13801/platforms”

Then use command:

“setfattr -x user.DOSATTRIB qwindows.dll”

Not sure if URL’s are allowed so replying to myself with the reddit thread where I found this advice: