Back to the main site

QMPlayer2 Starts When I Click "Browse File" (SOLVED)

I’m assuming there’s a balled up file association here, but every time I click on the “Browse Files” option in the application menu, QMPlayer2 starts and the link gets added to my playlist. Does anyone know what the format of that link is so I can fix this, or know how I can figure it out myself? :slight_smile:

Heh…
Come to think of it, whenever I click “View on Lutris.net”, it opens my file manager in my $HOME

As for your question, Lutris merely invokes system handler for file:// scheme (more specifically gtk_show_uri). I would expect that to be xdg-open for the directory, but in my case it opens spacefm --find-files "$GAMEDIR" instead of the default file manager (which is what xdg-open does if you pass a folder path to it).

…Correction: now that I checked it, it appears “View on Lutris.net” also opens spacefm instead of default file manager.

…Aand it also uses same call as “Browse file” in the code but passes a URL to Lutris website

…After a bit of digging, it turns out that URL handling is based on MIME handlers cache after all. Specifically, “Browse file” invokes inode/directory association, and “View on Lutris.net” invokes x-scheme-handler/https association (both listed in /usr/share/applications/mimeinfo.cache). I managed to change the former via xfce4-mime-settings, but I had to set up the latter by hand in ~/.local/share/applications/mimeinfo.cache.

1 Like

Thank you, you steered me in the right direction. In KDE Plasma System Settings it was under File Associations, inode, directory. I needed to remove the QMPlay2 references there. This was not a Lutris problem. :slight_smile: