Back to the main site

PSA: Problem opening wine games in fullscreen mode FIX

TL;DR:
If wine games are opening only in windowed mode and not full screen, try using X11 if you aren’t already.

I discovered something today which may help someone in the future.
I had previously set up a working installation of BF2 in lutris (and in Playonlinux as well) and everything was working fine.
Today I installed lightdm (my system default is gdm3) in order to try solve an unrelated problem (external monitor detection), which it didn’t help, so I set my desktop settings back to gdm3 and uninstalled lightdm.
However, suddenly games which had worked perfectly before suddenly did not even launch. Looking in the terminal logs, I saw:
D3D9: EnterFullscreenMode: Failed to change display mode
This and other errors saying it was not able to launch in full screen. So, changing the game configurration to run in windowed mode solved the problem. But, after a bunch of head scratching and cussing at my computer, I finally found the real source of the problem and the fix.
Turn out that while trying lightdm, I had changed the settings to use wayland instead of X11. The solution was simply logging off and logging back in with X11 instead. This immediately resolved the issue.