Prompt for Steam even though Steam is running

I’m trying to run the Win version of Borderlands 2 in order to play co-op with other Win users. Cross-platform compatibility is currently broken because of an update.

When I click on the play button, I get a prompt to run Steam first, even though I’ve already got Steam running.


Is the running Steam in different wineprefix (or native)? Because in that case they’re not really supposed to know about each other…

Speaking of which, have you tried to install the game in native Steam via Proton (Steam+Wine integration)? It’s actually possible to do even when a Linux version exists:

(After switching, you’ll need to wait for the “update” to download, and probably go to Downloads screen and start the download by hand.)

1 Like

Thanks for answering. I really appreciate it!

I’m not sure I can answer the question. I have a win copy that I downloaded with Native2Proton and I put the shortcut in the Wine folder of lutris. So maybe it’s a different instance?

I tried forcing the game to use Proton in Steam, but I got an error that an .ini file was corrupted. I tried verifying the Steam files several times, but got the same error. I’m trying a reinstall.

I’ll let you know how that works.


Er… From the description, this Native2Proton thing appears to be merely requesting an install of the game via Proton (so pretty much the same as in that dialog, but from external link I guess).
Unfortunately instead of showing status for the game ProtonDB says it’s “native”, so I don’t know if this problem is something that happened for others. Although the newest entry in WineHQ (from June 2017) says running the game from Steam UI doesn’t work and you need to start it separately… (that’s running both the game and Steam via Wine though).

Thanks again for replying.

I finished the download and…it doesn’t run when forcing it to use Proton. I think I’ll enable the user_settings (??) file and see what the error messages are.

I did get the Native2Proton version to work as a game added to Steam. The problem before was the documentation on github was wrong for the setup options. The shortcut in Steam had to point to borderlands2.exe (not the exact file name) with nothing in the run option field. Originally the path was /bin/ and the executable was /bin/bash.

I still want to get the game running in Lutris though. How do I run Steam through Lutris?

Thanks again!

Is the game installed in the native Steam library? If yes, then it’s as simple as importing it from the list:

…Take note that it’s impossible to set up Steam to quit after the game finished, so if you don’t close it by hand Lutris will think the game is still running (also, if you try to run the game from Lutris with Steam already running, the game will start from the currently running instance, while Lutrus will think it quit immediately).