Back to the main site

Problems with playing Blizzard games since 2018-01-30


#1

TL;DR: Since the 7.3.5 patch update, WoW has been complaining that my machine is running a 32 bit OS, and I must upgrade to a 64 bit OS. Since the pre-order patch dropped, I’m having problems getting the WoW page on the battlenet launcher to show me a play button - all I get is the background with a swirly thing. Diablo works fine. Hearthstone has issues. Using Ubuntu 17.04, Luntris 0.4.13, and wine version overwatch-2.15-x86_64.

More explanation: I had previous posted a request under the title “Problems Launching WoW, Hearthstone through desktop app” – I had wanted to make that a link to the post, and the system won’t let me cause I’m still a new user - and I admit I didn’t reply to Dox, partly because I didn’t understand the question, and partly because I had Life Issues attack. Things worked well enough, and it seemed that setting whatever it was I set to ie8 was sticking again. Since a few weeks ago, I’ve been having a wine error screen saying something like “helper.exe is having problems” with a close button, that comes back no matter how often I close it. Ignoring it doesn’t seem to cause a problem, so I’ve been doing so.

Since the 7.3.5 patch, I’m getting the battle.net app looking like this:

I went into Lutris, clicked on the word Lutris in the menu bar, clicked Manage Runners, Scrolled down to Wine, and got a list. I saw that the overwatch version was up to 2.17. I clicked on that and it downloaded, and also staging 2.18, 2.21, and 3.0 just in case. I made a launcher that used overwatch 2.17 and launched, and it showed everything as fixed on the battlenet app. I launched wow and played for a few hours - more than 2, less than 4 - and suddenly the game completely froze up. I had to X out of the frames to get the desktop launcher to exit, to get the game to exit, and I had to kill Battle.net+ and Agent.exe explicitly (using top). Since then, I haven’t been able to get it to work again at all.

I just tried to use the instructions at (http)lutrisDOTnet(games)world-of-warcraft --that would be a link, but I can’t put another one in here – using the dxd11 download. I was following the instructions that were in the windows popping up as it installed. The 'Helper.exe has a problem" error popped up just after the login screen did. I closed the login screen, and then clicked the new launcher listed in my lutris window, and got an error message of “The file /home/myname/Games/battlenet/drive_c/Program Files (x86)/Battle.net/Battle.net Launcher.exe could not be found.”

So I’m clearly doing something wrong, but I don’t understand what it is. Unfortunately, died in December (part of those life issues I mentioned) and he was the one who was better at figuring things out. I can follow explicit instructions, and am very confortable in linux (having worked with Unix most of my working career, till I was unable to work anymore) but searching for instructions, searching for solutions, blending them as needed … not my forte at all.

If someone could help I’d be very grateful.


#2

Battle.net Helper.exe’ crashing is happening to everyone. I still have no clue what it does. Though today it started to be ‘SystemSurvey.exe’ instead. I just click ‘ok’ on that.

Now back to your problem:

  1. Make sure you have your actual game data outside of the Wine Prefixes Lutris creates. That is the “World of Warcraft” folder, the “Hearthstone” folder, the “Diablo III” folder, etc. If you initially installed the games in the virtual C:\ drives, just locate them with your file manager, and move them to a location where you have enough room. For example: /home/YourName/Games/. (This is just to assure you don’t have to redownload the games later).
  2. Now delete the World of Warcraft Game from Lutris, and everything the Lutris game folder (this should only contain Blizzard App now, and we will reinstall this in step 3.)
  3. For World of Warcraft, start a new install for the DX11 version.
  4. One you get to the “Login In” screen, just click Ok on the error, and close the login screen.
  5. Open a terminal, and run “killall Battle.net.exe Agent.exe”. (I think this is the step you missed.)
  6. The Lutris installer should now complete.
  7. Now you should be able to start Blizzard App. Log in.
  8. Locate the World of Warcraft folder you moved to “/home/YourName/Games/”. Blizzard App will check your install and update if needed.
  9. Play.

Now if you want to install any other games, I suggest you press the install scripts of those games. This will give you a copy of Blizzard App for each game, but each will also have some game specific settings, and instructions specific to that blizzard game.


#3

So I’ve been trying to figure out why, but I cannot reinstall Battle.net at all. Was trying to follow your instructions, and i have all my games backed up, but the battle.net installer always gets close to finishing but crashes with an error. and my backup crashes after the SystemSurvey popup. Just started to do so a few days ago.


#4

i use staging-2.21 and it works with no issue.


#5

I know I’m kinda late to the party here, but I’ve got a question for you:

What do you mean by the “Wine Prefixes Lutris creates”? Do you mean that at some point, Lutris defaulted to placing games somwhere other than /home/YourName/Games/? Or are you saying that we need to move the folders for the games out of /home/YourName/Games/?