Back to the main site

Problems with overwatch update and new installs

I am using Ubuntu 22.04 and have been playing Overwatch for a very long time on it, so I am confirmed as having all pre-requisites installed for it. It started with a looping update to my existing Overwatch install. About a week or so back, Overwatch released an update that just looped on “an update is already in progress”. So I opted to dump and reinstall Overwatch from scratch and ran into issues there also. Initially I could not even get Battle.net to install but got worked through that by forcing the usage of an older wine inside of Lutris. But now I am at a point where Overwatch will not install from within Battle.net. I have tried every version of wine back to the 5 series and same problems that are similar to the update loop. In my lutris wine environment, I can see errors and logs slowly looping and getting added to the log and error folders under wine c:\ drive and it never comes off of 0% installed.

1 Like

It was working last night but the script appears to have been updated 6 hours ago? It was at least playable with the old script…

This is a battle.net problem - look through the other threads on this forum from yesterday to see how to get around this. The issue is with the Agent.exe file in Agent.8009 directory having some missing dependencies and at present there are workarounds for installing and downloading games that require replacing the faulty Agent.exe file with the previous Version 7984 file. I am not on my main computer atm so this is as much as I get with my phone.

1 Like