Problems with installation-scripts in Lutris

Hi there, after reinstalling my computer I keep running into a problem when trying to install a game. It’s right after clicking “Install” to start any installation script. Screenshots:

I do receive an error regarding screen size width, not being accessible, not really sure how to fix that though. Anyone seen this problem before? (I have generated the JSON file but don’t seem to be able to upload it? )

It appears that DBus fails to retrieve display mode from Mutter. More specifically, the call


returns None instead of the display mode data (where Monitor.get_current_mode() returns first value in its [1] sublist that includes 'is-current' in its [6] field).

Whether that means an issue with DBus, with Gnome, or with display setup, I can’t say, but those are you may want to check (look up possible issues/fixes with those for your distro).

Thank you for your response LeXofLeviafan, and sorry I didn’t reply immediately.

I believe you’ve pointed me in the right direction, as after a few days of trial and error (and a re-install of my system) I think I’ve narrowed it down to being a problem that stems from my Gnome configuration, running on Xorg, due to proprietary nVidia drivers.

The installation window does seem to work on Wayland, though I’m missing Vulkan support to launch the given game (available when running on the Nouveau driver).
Furthermore while running on nouveau, displaymanagement OS-wide doesn’t seem too smooth (display settings crashing, one port not working etc.) so I kinda need the nVidia drivers. But I can’t seem to be allowed to use Wayland in combination with these drivers, after some research I’m led to believe it’s not possible? At last the only workaround I found was adding nvidia-drm.modeset=1 to my boot parameters, which doesn’t seem to work for me.

Any input would be greatly appreciated. :slight_smile:

Technically you should be able to set driver parameters in system config; for instance, here’s my /etc/modprobe.d/nvidia-drm.conf:

options nvidia_drm modeset=1

That being said, both Xorg and proprietary NVidia drivers are used extensively, which means they shouldn’t be the cause of your problem; in fact, I’ve run Lutris on that exact combination for months with no issues. (Speaking of which – try downloading previous Lutris release and running it, to check if the issue is local to latest release.) So the most likely source of the problem would probably be the libraries used to access Xorg state (problem with your DE, perhaps?… Try switching to XFCE or something). That, or the DBus being broken for some reason (security permissions?).

Thanks for the fast reply. I’m actually quite happy to hear that it probably isn’t where the error occurs.

In Lutris 0.5.4, when I run the install script, the previous problem, where the installation window doesn’t show any content after clicking install, does seem to be fixed. The version doesn’t seem to be able to locate previously installed games properly though (i.e. game isn’t listed in the Lutris Library, is found to already be installed when running installation script, though running it results in “No file provided”.)

In XFCE Lutris (0.5.5) seems to work fine. Except it suffers from the same problem with problems remembering earlier installations of the game.

I don’t really know anything about DBUS, but that suppose that would be ruled out when XFCE works?

I’m not sure what ‘remembering’ is supposed to mean, exactly, but the installed games list (as well as local-specific fields of configs) is stored in ~/.local/share/lutris/pga.db (and the main configs are in ~/.config/lutris/games/). If you hadn’t kepts those between reinstalls, I don’t think there’s anything for Lutris to ‘remember’.

Perhaps this is the behaviour you get when you retained game configs from previous install, but not the games list? Directory/executable paths are stored in it, after all.

My guess would be, something in that DE breaks it (directly or not) :smiley:

Hey, so I just wanted to reply after fiddling a little more with it.
They released the 0.5.6 beta on the Discord channel, which seems to fix all the problems I have been experiencing in 0.5.5 while in Gnome, so that’s fantastic :smile:
Still not quite sure what caused the problem but, if it works right?

And thank you so much for your help troubleshooting, LeXofLeviafan! :grin: