Back to the main site

Problems with Diablo 2 Resurrected

Ubuntu 18.04 (I think, unlless it’s .10). Yes, I know 20 is out, but when I tried upgrading, it gave me an update to my nvidia files that locked my gui up such that I couldn’t login via it or use it at all. Sticking to 18 for now.

  1. I have an installation in my lutris folder for Battle(.)net, through which I play World of Warcraft. I purchased and (thought I) installed Diablo 2 Resurrected via that Battle(.)net. When I try to run Diablo 2 by launching it from there, I get a window frame with a grayish color that mostly looks like it’s not rendered/populated, and then it crashes, giving me the Blizzard crash reporter.

  2. In my lutris window, I clicked ‘lutris’ in the library side-pan and connected to my account. I put “Diablo 2” in the search window. I get (in list view, rather than icon view) “Diablo 2 Resurrected” and under year “2021” and the rest of the line is blank. Also, “Project Diablo 2” and year “2020” and the rest of the line is blank. When I choose Diablo 2 Resurrected and click ‘install’, nothing happens. I accidentally chose Project Diablo 2 and install, and it ran for a bit and then got hung in a loop that I irritatedly exited from without grabbing the error to report here.

  3. When I logged into lutris(.)net and searched for Diablo 2 Resurrected, it finds nothing. Searching for Diablo 2 finds Project Diablo 2.

What am I doing wrong?
Barleduq

1 Like

Issues here too with “Project Diablo 2”.
I’ve installed from .iso image, local installation. Everything went fine. When I try to fire the game, the starting screen appears. No sounds.
When I ask to “Play”, I get a message saying:
"Failed to load game data files.
Please reinstall Project Diablo 2 into a valid Diablo 2 LoD directory

  • OK"
    I don’t understand what this means, or what the “valid Diablo 2 LoD directory” is since the installer run smoothly.
    I run on a Pentium i5-2k (2011), 16GB RAM, NVidia 1030. Linux Mint v19.3 XFCE.