Problems launching WoW, Hearthstone through desktop app - Not sure where to ask, starting here

tl;dr: WoW fails to launch with the following errors, as seen in the screenshot. It will do this from zero to 15 times in a row (at which point I usually flip tables reboot and start over. Is this something Lutris can fix, and how? Additionally, when I try to launch Hearthstone, I get the window frame and audio, but the frame is black. Both of these complain about windows xp being deprecated. We’ve tried to tell Lutris to use later versions of windows, but it refuses to keep the setting. How do we fix this? Ubuntu 17.04, Lutris 0.4.13. Not sure what else you need to know, please ask.

Chatty version, more details:
Hi there I started using Lutris a month or so ago, when we switched to Ubuntu from Fedora. I play Blizzard games (WoW primarily, secondariily Diablo, with occasional forays into Hearthstone, HotS, and I’m hoping to start with whatever version of Starcraft is now free to play). After much fiddling, we’ve finally gotten the desktop app to launch correctly and have all of the visual details it should have - play/install buttons as appropriate, ads/informational boxes on the different screens, that sort of stuff that was missing before we forced lutris to use ie8.

Still, when I try to launch WoW, it will usually give me an error - I get the big ‘please tell us what went wrong’ from blizz, along with an error message complaining about a command at memory location X trying to run a command at memory location X, and failing. Within each error screen the memory locations listed are the same, but they are different on different failed attempts. Note, sometimes I don’t get this error at all. Sometimes I’ll get it a few times in a row. When I’ve gotten it 15 times in a row, I usually reboot the computer just to try to get it to put things in different places in memory while I go out of the room and get less irritated. (it’s better than flinging the machine out the window.)

In trying other games to see what worked, Diablo3 with Necromancer works fine. Heroes of the Storm refuses outright to run, saying that the OS is unsupported. Hearthstone says it’s unsupported, but allows me to try to launch, and I get the window frame, and audio, but the screen is black. If I click on places, I can hear things happening, and it tries to start a game, but since I can’t see anything I can’t do anything, and I force quit. I don’t have anything else installed.

We’ve tried to tell Lutris to use a higher version of Windows, and it doesn’t work - the setting doesn’t take. We just figured out the ‘force ie8’ yesterday, which made a lot of things work, but that didn’t stick either. I had to re-set that today after I rebooted after wow failed to launch. So I made an account and I’m posting this, hoping to get any help at all.


Thank you for any help you can offer.

Are you using the individual installers for the games? The installer is just to have a standalone client to test stuff with. The individual installers set stuff up specifically for each game.