Back to the main site

Problems installing Starcraft II

Trying to install Starcraft II through lutris after updating to Ubuntu 22.04. I worked when I was using 21.10. The output of lutris -d is here: Ubuntu Pastebin

It gets to a certain point then gives me this message:
Started initial process 69251 from /home/madjestyr/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/bin/wine /home/madjestyr/.cache/lutris/installer/starcraft-ii/setup/Battle.net-Setup.exe
Start monitoring process.
Monitored process exited.
Initial process has exited (return code: 256)
All processes have quit
Exit with return code 256

Like I said it worked just a couple weeks ago no problem. After updating to Ubuntu 22.04 is stopped working. I also reinstalled Ubuntu 22.04 from scratch and it still doesn’t work.

Edit: I reinstalled Ubuntu 21.10 because 22.04 was giving me other problems. It still won’t install Starcraft II. Hearthstone installed just fine.

1 Like

It seems the problem has been rectified by installing Lutris through: ppa:lutris-team/lutris-staging. Not sure what it is though.

How did you install lutris initially? I think the ppa installed the missing dependencies.

The staging part I believe it has wine-staging as dependency and is a crucial part for wine from system side.

Initially I installed the ppa with sudo add-apt-repository ppa:lutris-team/lutris then sudo apt update && sudo apt upgrade, then sudo apt install lutris. Starcraft II would never finish loading as I said in the OP. Then last night I found the staging ppa and installed lutris through that after doing a sudo apt purge lutris. Starcraft II installed without any problems after that.

Thank you. I had a similar error (also return code 256). But after using ppa:lutris-team/lutris-staging instead of ppa:lutris-team/lutris the installation worked fine.