Back to the main site

Problem starting Classic WoW with Lutris / Manjaro

Hi, I’m new around here,

I’ve been trying to install Classic World Of Warcraft, but it has been a headache for me.

When I click on “Play” it simply does nothing, being in the launcher.

This is the error output:

Running /usr/bin/wine /home/crail/.wine/drive_c/Program Files (x86)/World of Warcraft/_classic_/World of Warcraft Launcher.exe

`<html><head><title>Object moved</title></head><body>`

`<h2>Object moved to <a href="` [ `http://www.blizzard.com/404` ](http://www.blizzard.com/404) `">here</a>.</h2>`

`</body></html>`

`<html><head><title>Object moved</title></head><body>`

`<h2>Object moved to <a href="` [ `http://www.blizzard.com/404` ](http://www.blizzard.com/404) `">here</a>.</h2>`

`</body></html>`

`<html><head><title>Object moved</title></head><body>`

`<h2>Object moved to <a href="` [ `http://www.blizzard.com/404` ](http://www.blizzard.com/404) `">here</a>.</h2>`

`</body></html>`

`Waiting on children`

`Waiting on children`

`Waiting on children`

`2019-12-28 08:39:48,424: Unable to read stat for process 30374`

`2019-12-28 08:39:48,433: Unable to read stat for process 30374`

`Waiting on children`

`2019-12-28 08:39:49,989: Unable to read stat for process 30390`

`2019-12-28 08:39:49,989: Unable to read stat for process 30390`

`2019-12-28 08:39:49,989: Unable to read stat for process 30388`

`2019-12-28 08:39:49,989: Unable to read stat for process 30388`

`Waiting on children`

`libGL error: No matching fbConfigs or visuals found`

`libGL error: failed to load driver: swrast`

`X Error of failed request: GLXBadContext`

`Major opcode of failed request: 154 (GLX)`

`Minor opcode of failed request: 6 (X_GLXIsDirect)`

`Serial number of failed request: 219`

`Current serial number in output stream: 218`

`Waiting on children`

`2019-12-28 08:40:05,447: Unable to read stat for process 30484`

`2019-12-28 08:40:05,447: Unable to read stat for process 30484`

`Waiting on children`

Btw my old setup:

AMD Athlon X2 240

Nvidia GeForce 9500GT

Manjaro 18.1.4

I’m on Wine-Staggin

I have followed Lutris’ guide, and I continue with the same problem.
glxinfo log:
https://pastebin.com/gUHp872q

Need help, please.

I think swrast means software rasterizer. I had similar problem and I must do something with GPU drivers. Does native Linux games, like Tomb Raider, Civilization V/VI/BE or other works?

Are you using Framebuffer X11 backend?