Problem launching the Wargame client to launch world of tanks in Rosa R11. 1

The problem itself is in the screenshots

information about the system.
nikolanp@nikolanp-desktop ~ $ lspci | grep -E “VGA|3D”
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630] (rev a1)
nikolanp@nikolanp-desktop ~ $
nikolanp@nikolanp-desktop ~ $ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 630/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.138
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.138
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.138
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
nikolanp@nikolanp-desktop ~ $

operating system: rosa desktop fresh 11.1 2016.1
KDE Plasma version: 5.14.4
Qt Version: 5.11.2
kde frameworks version: 5.53.0
kernel version: 5.4.72-generic-1rosa-x86_64
Architecture: 64-bit
processors: 6 × amd fx ™-6300 six-core processor
memory: 7.7 gib ram

I’m by no means an expert with Linux/Lutris, but I’ve had similar issues getting World of Warships to work with the WGC. Also, I’m using Fedora 33 on my computer. I’ve never heard of Rosa before. For all I know, these suggestions may not work on it.

What fixed it for me was trying to use different Wine versions. If you right click on the WGC client and go to Configure > Runner Options > Wine version, what version are you using? I find that the client launches properly when using version "lutris-5.7-11-x86_64.

Try changing the Wine version to try them all out until you find one that works. In the past, I’ve also had to use the version that is installed with Magic the Gathering: Arena to get it to work, or Glorious Eggroll’s version of proton (lutris-mtga-5.0-x86_64, and proton-5.9-GE-8-ST, respectively). If you want to try Glorious Eggroll’s version, you have to download it from his github here:

You have to extract the the downloaded directory from the tar.gz file and move it to this directory: /home/USER/.local/share/Steam/compatibilitytools.d
Also, you have to make the “compatibilitytools.d” directory; it’s not there by default. From here, restarting lutris (or steam) will allow the proton version to be chosen as the Wine version in each application.

Some other useful links:

Also, I haven’t tried it myself, but worst case scenerio, I’ve heard that you can run WoT through Steam, if that’s something you’d be interested in. I heard that there’s a way to sync your account with your Steam account and then just run it from there using Proton. I don’t know anything about the process for it though, so can’t really help you there.

I hope something in this wall of text was useful!