Prince of Persia 2008 install fails

Hello! First time posting here and of course it is with a problem. :laughing:

I tried installing Prince of Persia (the 3D one from 2008) from GoG. I downloaded the installation files from GOG-website and startet the installation via Lutris. I skipped the GOG login as this does not seem to work at the moment and picked the installation .exe from my hdd. The script prepared the WINE prefix, but then instead of launching the installer it only showed me a MS Windows styled dialog box telling me “file not found”. And then there only the WINE prefix has been put into the PoP folder.

So, what now I ask? How do I make it install? And how do I get the log that is shown while the install is running? clicking on the log icon below the launch button for Prince of Persia I get an empty window.

System used: current Linux MINT19.3 and Lutris 0.5.6.

So I found the lutris -d option and put the output on the ubuntu pastebin:

https://paste.ubuntu.com/p/CqxCfbpXYG/

I hope that helps in any way.

How many parts do you have? How many parts should you have? If you have the right numbers parts are the filenames correct?

The three that GOG gives me for download:

'setup_prince_of_persia_1.0_v2_(28572)-1.bin'
'setup_prince_of_persia_1.0_v2_(28572)-2.bin'
'setup_prince_of_persia_1.0_v2_(28572).exe'

Install on Windows10 works without problem and runs, as I have tested in the meantime. So something else must be wrong.

That’s normal, the game should be installed inside.

Keeping the log consumes CPU, so it won’t start logging until the log window is open.

Lutris runs GOG installers in silent mode, so the window doesn’t show up. Chances are, the “file not found” refers to the game executable.
If you run the installer manually (using Wine; use the “Run EXE inside wine prefix” option of the game link), it should display the default install location; compare it with what’s set up in the game link config. Chances are, it’s there (you can check it by going in drive_c/ subfolder of the wineprefix), but the path in the Lutris installer is outdated. If that’s the case, update the game link config; and if the game link started working, also update the game location in the install script accordingly (don’t forget to write down the update reason and submit the update).
…If the game isn’t installed in the wineprefix for some reason, just run the installer again and complete the install.

This is exqactly what happens. Install is not completed. It ends with a window asking for putting an icon on the desktop and a link in the menu. This last message window also says that the games .exe cannot be found. In the directory of the game is only the WINE prefix installed and zilch, zero, nada of the game. So it obviously does not launch the installer or the installer aborts.

I am going to try out your steps tomorrow. btw I found trying out other installs the very same problem with The Next BIG Thing. I guess that is the next to get a submission of a hopefully a working correction. thank you so farI am off to bed now. :sleeping:

I said “run the installer”, not “run the install script”. The most likely reason for “executable can’t be found” error is that it looks on the wrong path (because it was changed by GOG in the new installer, again).

Sorry. Yes, that is what you wrote. I should not post that late. I did run “Run EXE inside wine prefix” on the stumped installation and it still throws that file not found dialogbox at me (actually it says “Datei nicht gefunden” in German). :frowning_face:

Lutris -d says this on the terminal after having pressed that Ok button:

(…)
DEBUG 2020-04-19 15:19:56,551 [command.start:135]:ENV: PYTHONPATH="/usr/lib/lutris:/usr/games:/usr/lib/python36.zip:/usr/lib/python3.6:/usr/lib/python3.6/lib-dynload:/usr/local/lib/python3.6/dist-packages:/usr/lib/python3/dist-packages:/usr/lib/python3.6/dist-packages"
Running /home/knut/.local/share/lutris/runners/wine/lutris-5.6-2-x86_64/bin/wine /home/knut/Downloads/gog/prince_of_persia_2008/setup_prince_of_persia_1.0_v2_(28572).exe
Initial process has started with pid 19695
Game is considered started.
Game is considered exited.
Initial process has exited.
All monitored processes have exited.
Exit with returncode 256
DEBUG 2020-04-19 15:20:50,583 [command.on_stop:182]:The process has terminated with code 0
DEBUG 2020-04-19 15:20:50,584 [command.stop:266]:Management process looks dead already.
DEBUG 2020-04-19 15:20:50,584 [command.stop:274]:Detaching logger

But on my roomies win10 computer it installed without a hitch and launched. This starts to look like a bug in the gog installer as you say. The gog setup does nothing except show me that damn box as seen in the screenshot. No dialog to pick an install directory or anything. It starts, then a moment of nothing and a bit of hdd activity and then the “file not found”.

Looks like we cannot do much about it. I have already written to GOG support, but apart from “download the setup files again” in an automated email reply not much came so far. And they don’t do WINE support I guess.

…This. Have you done this?

Hello, I just updated the script, could you tell me if it works now?
I can not verify, I don’t own the game.

1 Like

…This. Have you done this?

Yes. I started the isntaller from inside the WINe prfix, butit did still throw the same error message and then I just launched the installer.exe directly , which actually did run, but then of course the required registry entries were not in the prefix, so yeah, did not work in the end, but the installer seems to work at least. So the problem is somewhere with Lutris.

I’m not asking you whether the installer works; I asked whether the path matches or not.

Thank You. Install ran through throwing a runtime error at the end:
“Runtime Error (at 211:814)
out of Global Vars range”

Then a window poped up, warning me that the isntalltion did not complete. I tried to launch it anyway, but there was no executable and no file folder where it was supposed to be. I had left it all at default. where did it drop all those unpacked files? There was HDD activity all the time to the end.

I ran Lutris from the terminal and this is what it spit out there: https://paste.ubuntu.com/p/dBdttwCPRw/

Sorry, I forgot to post and left the tab open. :upside_down_face:

Sorry, that I misunderstood you.

Which path? the installer script proposes “~/Games/prince-of-persia-2008” and then the gog windows installer proposes “C:\GOG Games\Prince of Persia”

So which one should match to what then?

Naturally, the Executable path in the game config should point to the location of the game executable within the wineprefix (starting from drive_c goes the part equivalent to the C: path in Wine).


The GOG installer tells you which folder it installs the game in (and while the path within the folder is unlikely to have changed, you can easily confirm it by checking in a file manager); the install script is supposed to set that same path in the Executable field of the game link for it to be able to actually run the game.

Did you ever get this working? I just installed it and it worked fine for me - maybe worth giving it another try?