Back to the main site

Post-exit script not working

So here’s the problem i’m writing a simple python script to upload my save files to a google drive folder to create a sync system between my phone and pc when i play pokemon.
The script works fine but now i would like to make the thing a little more automated and not having to launch it manually everytime, i’m not a caveman afterall.
Now from my understanding the post-exit script feature needs a .sh script to work so i wrote a very simple one like this

#!/bin/bash
python3 path/to/python/script

and when i launch it manually it works flawlessly but when i tell lutris to run it after the game closes nothing happens, can anyone guess why? Is it the runner ? I’ve tried both desmume as standalone and melonds as core in retroarch but neither worked. I have to do something to close the game properly? i’ve tried both clicking on the x on the emulator window and on stop game from inside lutris and nothing works.
Is there a way to show what goes wrong? the show logs option from the configure game window shows nothing so i’m really running out of ideas.
This is my config

2022-08-08 18:19:48,155: Starting Lutris 0.5.10.1
2022-08-08 18:19:48,293: Running AMD Mesa driver 22.1.4 on AMD Radeon RX 5700 XT (navi10, LLVM 14.0.6, DRM 3.46, 5.18.16-arch1-1) (0x731f)
2022-08-08 18:19:48,294: GPU: 1002:731F 1DA2:E411 (amdgpu drivers)

i’m on wayland, thanks in advance for help!

1 Like