Possible to run games on Lutris and/or Steam Proton?

This may be on old already answered question, but I did not find a post resolving it.

Recently, I attempted to get Elite Dangerous: Odyssey running via Steam Proton. While digging around, I found a comment that using Lutris might be easier. Oddly enough, while researching Lutris information, I found out how to get it working on Steam. (go figure)
It runs, marginally playable.
My question is this:

Is it possible to run a game using Lutris that is already installed and working with Steam Proton?
And, is there any information on how to achieve that?

I’d like to see if one works better than the other - without having to uninstall/reinstall/rinse and repeat…

(For all I know, Lutris might just call Steam Proton.)

You can run games installed in Steam (native) from Lutris. Lutris does call Steam (native) to load and run the game. Not sure on the winblows version of Steam as I have not used it for a very long time. Personally, I run all my steam games directly from Steam (native).

To load your Steam games in Lutris, you need to click on the gear icon next to Steam under Sources. You might also have to verify the login of Lutris through Steam (been a long time so not 100% sure on the verify part), Running games from GOG, EA, etc is the same, except you need to install the EA app, etc.

Not sure if you are aware of protondb.com but it gives you a lot of information on what games run on Linux, and any tweaks you could try to make the game work.

Something else to look at and try is protonUP-qt Releases · DavidoTek/ProtonUp-Qt · GitHub. This will add GE releases for Steam, wine and Lutris. helped some games of mine go from insta-crash to running flawlessly. Using the AppImage is the easiest way to install it, but there are a lot of other ways to add GE.

Hope this helped a little.

Absolutely fantastic info, thank you very much.
Most of this was expected to be a dead end. But, when I got Elite Dangerous to load and run, I have to admit, I was in shock. It took a few tries with different version of Proton. Looking at different posts made it clear that there was no single version to “rule them all” (very punny, I know).
Actual order of testing via posts I was reading:
suggested Experimental - Nope
suggested V8 - Nope
suggested V6 - Nope
5 - Nope
why did I not see V7 suggested? A few dozen posts later it was.
V7 - Bingo. lol
I just sat and stared for a few, then moved my commander around a bit. Seeing that things basically worked, I logged out and began looking for optimizations.

Things got a little busy for me and I let this go for a little bit. I’m doing some upgrades to my old linux box to make it a better second gaming system. (* planned upgrades)
Right now, it’s running on an ancient MSI 760GM-p23 a salvaged CyberpowerPC
FX6300 (*FX8320E)
G15 Keyboard (cleaned and revived)
Corsair M65 RGB mouse I had repackaged to return to Corsair for bouncing new-out-of-the-box. Oddly enough, it works fine on this computer.

The entire system is more-or-less held together by good intentions. :wink: It’s been very stable through all of the upgrades and updates starting with Linux-Mint 20.1.

What started as a lark - a simple system running linux, to have a second computer, has turned into a serious revival project. But, that’s usually the case, most of the time.

I will check out ProtonDB and keep at it.
Thank you again,