Back to the main site

Playing Northgard in Linux with Proton

Hi,
I used to play Northgard in Linux for over a year now, but not the native version of the game, because OpenGL lacks in Performance.
Since some Updates neither on my System or on Northgard I have some Kind of wierd Grafics:

Its allways there, when i use Vulkan (DXVK or Zink) and it affects all elements (menus, game it self).

What I have allready tried:
-changing Proton Version incl. 15 Proton GE versions
-Setup different Parameter (but way not all)
-searched Googl, Reddit, ProtonDB and others
-installed Steam in wine (usung Lutris) and then Northgard (the exact same result)

I hope somebody had this issue and was able to solve it.

Any kind of help is welcome.
thx

1 Like

Hallo mein Freund,
Can you put your HW info in an Ubuntu Pastebin and maybe some logs?
Also what driver are you using for your Radeon card?

Things I would try:

  • Disable the Steam Overlay
  • Set the game to borderless
  • I would try another DE (KDE, Gnome, openbox,…)
  • Rollback the mesa drivers

Also, I would not really use Lutris for Steam games unless you see a benefit for it.

Danke für die Hilfe, mein Freund. :smiley:

first things first:

Screenfetch:

lspci:

uname -a
inux endeavour 5.18.3-zen1-1-zen #1 ZEN SMP PREEMPT_DYNAMIC Thu, 09 Jun 2022 16:14:13 +0000 x86_64 GNU/Linux
GPU Driver:
mesa 22.1.1-2
Proton Logs:

If something is missing, let me know.

In the meantime I´ve tried a non Zen Kernel aswell. The same Result.

I remember, that I´ve messed arround with my gpu driver month ago. I´ve installed the mesa-git drivers and then a normal update didn´t work so I´ve uninstalled them and installed the normal once again.
This might be a problem but: every single other game works completly normal. And I have a ton of games.

You could try going for the amdgpu drivers but if everything else works then I suggest to change the settings in the game.

You could also try vkBasalt, it does some sharpening and you could add some post processing but the idea is that after the post processing the image is rendered properly.

Thank you for your reply and hint.
I´ve tried about 20 different shader but non if them seem to have any kind of effect on my problem.

In the meantime I´ve installed fedora on my system. And guess what, game runs flawlessly. -.-

I might have messed my system or something is wrong with arch(Endeavour OS). What ever it was, its gone with Fedora.

Good to hear that it runs. You should try vanilla Arch, I have not had any serious problem with it.

1 Like

I´m pretty familiar with arch. Using it since 2012. I had endeavour OS installed becaus I was lazy. :smiley: