Parts of the new Lutris GUI/other that I don't like

Since this is labelled a feedback forum and github is only seemingly for bug reports for Lutris, this is where I’m going to say a bunch of feedback.

There is a good amount of the GUI overhaul I like, but not these:

  1. Why can’t I right-click to get the same menus as the bottom? Having to left click, then click on things at the bottom, is redundant and annoying. The menus at the bottom are fine, so long as I can right click on things too.

  2. I can’t tell when this happened, but I can’t pick release versions of DXVK any more, only nightly builds. Earlier this year I do believe I was able to select release versions of DXVK based on the DXVK github release process. I really want to be able to select actual releases, not nightly builds of DXVK.

  3. When a game closes, the bottom menu goes away unless I select something. This is really annoying, please just don’t let the menu go away.

  4. Application menu shortcuts broke as soon as the GUI was overhauled. Really want to see this fixed as now I can’t use my tasty shortcuts on my dock, I have to launch from Lutris every time. Bleh :confused:

Hopefully this can get ready by some of the devs and get addressed!


For the desktop links not working anymore, I got it to work after a system update (Manjaro Testing branch) so I guess it requires some update to Python or something.

I globally agree that the new UI is now worst than what it was.

//EDIT: I can’t find how to search installers from within Lutris now. I need to go to Lutris website to click install…

I didn’t say Desktop Shortcuts, I said Application Menu Shortcuts…

I have to agree, the new GUI is a step back and does work correctly.

Which are the same files, desktop files, at different places.


I was searching for a way to restore the old rigth side panel, but it seems there is not…

For me, I consider the right side bar far better than the bottom bar : everything was accessible with a simple click without searching !
By the way, I’m only using the list view.

Maybe an option will be nice to get back to the old right panel.

(I tried to downgrade to 5.7.1, but lutris crash with a python error even after moving out the .config/lutris ?! I’m now locked on 5.8.1…)

The web runner don’t work anymore and we can’t edit them to correct them nor remove them. (EDIT : solved after installing the web runner again.)

Best regards,

the web runner don’t work? I can not reproduce this issue. Could you remove/reinstall web runner and try again?

After installing it, the web runner works again. Is was tagged as not installed ?! Oo

It seems the web runner as been totally reworked as it use now a ~79Mo package containing electron and co.

Thank you.