[PARTIALLY SOLVED] Fedora 24 - libretro : impossible to launch PSX games


I’ve tried to play Alundra & Suikoden on libretro PSX emulator (tried Mednafen & PSX Rearmed), they both quit with the error message :

~/.local/share/lutris/runners/retroarch/retroarch: symbol lookup error: /lib64/libXv.so.1: undefined symbol: _XEatDataWords

Diagnostics :

$ nm -D /lib64/libXv.so.1 |grep _XEatDataWords
                 U _XEatDataWords

$ objdump -T /lib64/libXv.so.1 |grep -i XEatDataWords
0000000000000000      DF *UND*    0000000000000000              _XEatDataWords

I’ve reinstalled libXv package but it changed nothing.
Not sure if it’s the real problem, since it seems related to Bumblebee …

Ok, in fact it was due to Lutris Runtime, If I disable it in the configuration menu , it works ! (at least with PSX Rearmed).

With PSX Rearmed it complains “No Bios Found, expect bugs”, how can I set the BIOS ?
In libretro wiki, it says to put the BIOS image "inside the frontend’s ‘System Directory’ ", what does it mean in lutris context ?

With Mednafen PSX (& OpenGL), it throws this error :

Attempt to read LBA 16, >= LBA 0
CDIF Raw Read error
terminate callef after throwing an instance of 'MDFN_Error'
~/.cache/lutris/run_in_term.sh : ligne 3 : 12787 Aborted
  (core dumped) 
"/games/PSX isos/Alundra_Pal.cue"

I answered most of this in the Github issue but you should still be able to run (some) games with Rearmed.

The problem you’re facing isn’t related to the BIOS but to the Lutris runtime, try disabling it to see of it works any better.