Palia - Problem with using Launcher

Hi everyone! I was able to get Palia working but I had to go back to Windows and update the game. If I point the exe to the launcher I get an error asking me to use admin and if I point to the Client exe it works but like I said - if the game needs an update it doesn’t work unless I go back to Windows. Any ideas? Thanks!


I am using World Of Tanks and the situation is similar. You need the launcher in order to update the game but the client doesn’t requires the launcher to works.

But, in order to make the things a little bit hard, we want the game clients launch the launcher to update when the game is outdated. (WOT says “The client requires an actualization” and shows a button “update”, if you click it the game launches the launcher.

I solved this in this way:

  1. In order to avoid the settings affects other games in lutris we will use a wine prefix for palia only:

    I used .wine_wot, but you could use by example .wine_palia

  2. In Lutris create a game “Palia Launcher”.

    • Set its wine prefix to ~/.wine_palia
    • Choose an adequate version of wine (could be not the same that the client use), change the runner until you get running the launcher.
    • In Lutris create a game “Palia”
    • Set its wine prefix to ~/.wine_palia
    • Choose an adequate version of wine (if you got the game working, you know which one is).
  3. When you want to run the launcher just launch “Palia Launcher” to update the game.

If your launcher ask for root permissions (in order to write in your directory to update the game) it is probably because your directory is not writable for your current user. You can solve it setting the current user as the owner of the directory. You can use a file explorer to do that, but it’s easier from the command line.

Suppose your game is in a directory called “Palia” inside your /home directory (folder if you come from windows) and your user is “claine”

Open a terminal, then type:
sudo chown -R claine:claine Palia

Please note commands and file and folder names in Linux are case sensitive.

Hope this helps.

Best regards.