Overwatch - Works for a moment then: "Your rendering device has been lost. Application closing."

Intel® Core™ i5-3320M CPU @ 2.60GHz × 4
Mesa Intel® HD Graphics 4000 (IVB GT2)
8GB memory
Fedora Linux 35 (Workstation Edition)
Linux fedora 5.16.15-201.fc35.x86_64

Lutris > Overwatch > Show Logs (paste.gg pastebin of log)

I have managed to get Overwatch installed an running using the Lutris provided Overwatch installer script. After getting the “general error” I followed the troubleshooting guide and added my GPU info to Overwatch’s settings.ini file:

GPUDeviceID = "358"
GPUName = "Intel(R) HD Graphics 4000 (IVB GT2)"
GPUScaler = "70.000000"
GPUVenderID = "32902"

When launching the game, the “Compiling shaders…” message appears in the bottom left hand corner. I am able to get into the main menu (or a training lobby, if I am quick enough). After 10-30 seconds the game’s graphics will freeze on the last frame. Sometimes the game is still responsive even though the graphics is frozen (can hear sound effects of UI mouse hover, walking, jumping, shooting, etc). And sometimes after freezing I will get an error: “Your rendering device has been lost. Application closing.” and then the game will crash and close.

I have tried to tweak and toggle some configuration settings in Lutris with no luck fixing this error. I have also tried adding __GL_SHADER_DISK_CACHE_SKIP_CLEANUP=1 to system options.

Any ideas?