Overwatch Ubuntu 18.08

I’m trying to install Overwatch on Ubuntu 18.04 with the Lutris Script.
Unfortunatly the Battle.net Installer crashes with “Required DLL could not be found” and Lutris stops with File not Found exeption
I installed every dependency exept “libldap:i386”. It does not exists under Ubuntu 18.04. So I downloaded and installed this deb-package: “libldap-2.4-2_2.4.45+dfsg-1ubuntu1_i386.deb”

Here is the Log from Lutris https://pastebin.com/W1cNzVXe

Did I forgot something to install?

I don’t think so.
My installation was working on 16.04 up to yesterday morning, then the Blizzard app updated and I started seeing this error yesterday afternoon. I tried reinstalling Battle.net and the error persists.

Same problem. Ubuntu 16.04 here. Last Batlle.net show this error about missing dll.

Info: Here is a post with this problem on battle.net https://us.battle.net/forums/en/wow/topic/20764376620

No solution until now ^^

1 Like

I don’t think I got this issue on my windows partition with the same Battle.net update, though.

I managed to get it to open by including these two dll overrides:

Performance in Battle.Net is severely degraded, though. I don’t know why. Haven’t opened OW itself as yet because it has an update pending.

1 Like

It worked! The Battle.net client seems slow, but Overwatch is fine.

1 Like

Do you know what I must do with the installer?
I can’t install it and so I can’t get to this window ^^

I’ve noticed sometimes to installer will timeout while downloading Battle.Net. I just keep retrying until it works.

For me the Installer stops with “Required DLL could not be found”
I can’t get over this point, because I can’t open the wine settings at this state.

same problem here

No idea what to do if the installer fails there. We may need help from someone with a little more experience that I have.

Tried reinstalling Battle.Net and started seeing this error:
Difficulty running or installing battle.net

I just did a fresh install this morning and it worked perfectly.