Overwatch not booting after initial install

Title. Button is greyed out after initial install and doesnt boot. No game logs are outputted.

lutris --submit-issue output: https://pastebin.com/Q26Tc8dJ

lutris -d output: lutris -d2022-09-10 19:51:46,455: Starting Lutris 19:51:46 - Pastebin.com

After installing overwatch (with all the dependencies needed for it and battle . net (i cannot post link to the github as im a new user)), the game refuses to launch once having closed the battle . net launcher for the first time.
The play button gets greyed out and nothing happens. The output of lutris -d is consistently $ABOVELINK (I cannot put more than 2 links as a new user)
Things I have tried:
-Reinstalling overwatch
-Reinstalling overwatch on a different drive
-Reinstalling lutris
-The solution under “Sleeping Agent / issues with installing / updating :” on the battle . net github page that im not allowed to link.
I would like to point out that I’m using KDE and battle . net has a known problem with this DE as pointed out in the above link. This is NOT my issue, and the issue pointed out there is not what is happening to me.
On previous installs, I did not follow the installation instructions properly and installed overwatch at initial startup. The game and battle . net launcher worked great. But i had the same issue as described above.
This issue seems to only be with booting the game up after the initial install of battle . net. Please help, I really want to play overwatch before it goes away forever with overwatch 2, and I’m very new to linux in general.
OS: Kubuntu 22.-4.1 LTS 64bit
DE: Plasma 5.24.4
CPU: AMD Ryzen 7 3700x
GPU: NVIDIA GeForce RTX 2070 Super
16gb ram @ 2400mhz

lutris --submit-issue got removed. updated link: Ubuntu Pastebin

After battle.net installer took you to the login screen, did you login and download the game? or did you close the login screen, allow the battle.net script to finish and launch it from Lutris and install the game this way?

nvm - you tried both ways. What runner and runner options are you using?

I have tried it both ways in an attempt to get different behavior for my issue, uninstalling overwatch and lutris in between attempts. Both ways (including the correct way - the second way you mention) result in what I have posted.

What Wine version (runner) and runner options are you using?


I hope this is what youre asking for? I included screenshots of the runner options

Did you confirm you installed the 32 bit nvidia drivers?

I ran the command given to me for this here: docs/InstallingDrivers.md at master · lutris/docs · GitHub , including rebooting my pc

Running the command again and it says the driver is already the latest version, and as such it doesn’t do anything.

Is there another way to confirm they’ve installed ok or is this enough?

Yeah that should be fine. The button that is greyed out - is that the button on Lutris or on the Battle.net launcher?

The button on lutris. No new window appears after clicking play on lutris, the button is greyed out until i force close lutris (and even then sometimes its still greyed out after that!).

The python error shown in my lutris -d output occurs almost instantly after clicking the play button in lutris.

In the runner options, try disabling esync and then start the battle.net launcher

No luck unfortunately, the same error is outputted to terminal (i started lutris with lutris -d again)

I want to double check however that by “start battle.net launcher” you mean launch overwatch within lutris, right?

this is what my lutris looks like

check in your activity viewer (system monitor) to see if there is either a agent.exe or battle.net.exe process started. Also, the version of lutris you have is the older one, the new version is but I don’t know Xubuntu to know if you can update it via sudo apt update

I fixed it! Woooo!

This is the error I was getting, I guess I didnt find it straight away when initially googling the error.

I fixed it by following the comment in that thread, (adding a None to the .pop method call in a config file), but it looks like this was updated in the version of lutris you mention (0.5.10), so I suppose anyone that updates should have this fixed?

Thanks a bunch! :slight_smile:

I would check that.