Overwatch general error 0xE0010160

I’m getting Overwatch general error 0xE0010160 whenever I run Overwatch after installing and downloading.
I figure this has something to do with driver support, but I don’t know how to troubleshoot it.

I’m on Ubuntu 16.04. Screenshot with specs:

I don’t have a discrete GPU as yet.

Yeah, I pretty sure Overwatch won’t run on the Intel iGPU, you can always try bleeding edge versions of Mesa but I still doubt it’d run at all.

You’ll need a beefy GPU to make it enjoyable, I tried it with my GTX 970 and it was borderline playable.

I got myself a 1060 and it works almost perfectly. It stutters here and there (loading textures and models maybe), and freezes sometimes right after a game completes.

Didn’t mean to ‘revive’ the post, but did you find any solution to the problem?

I didn’t want to start a new thread but I encountered the exact same error T-T
Battle.net works fine but when I click play there is a black screen and some seconds later the general error 0xE0010160 appears.
There are mentions with hardware, I’m not with Intel iGPU but AMD Radeon, it is possible that I forgot to configure something as I just recently installed arch linux and I’m new at it, even though I don’t know what it can be. Also, I would understand a stuttered game, but it doesn’t even start D:

I literally have no idea how to proceed, any help or idea will be appreciated

You’re on an AMD CPU? I wanted to try it on mine (different PC), but never got around to it. I’d recommend you pick up an 1050 for around $100 and it should run like a charm, except for the voice chat. Mine crashes if I leave voice chat after someone’s spoken.

I am!
I couldn’t make it around the error :c
For what I searched it is indeed problems with drivers, but even after I blacklisted radeon for amdgpu things haven’t changed :cry:

@Vitamax: I still don’t think you are actually using AMDGPU.

@thurst306: The freeze issue with voice can be fixed by setting the voice communication stream to “Voice Comm”. That will make the game output 2 different streams instead of 1. Using Pulseaudio you can then route them back to the same output or to different outputs.

1 Like

I’ve got it set to “comms devices”. I’m not seeing “Voice comm” anywhere. See the screenshot here:

Yup that.

Was that the only change you made? Upgrading your GPU to a 1060 made the error go away?

Yeah, it runs like a charm on the 1060 (minus known issues).