Overwatch DX11

This installer for Overwatch works flawlessly (so far) on my AMD machine without the graphics card. I just wanted to shout out to whoever did it, you did a wonderful job. Thank you.

I will be testing with the graphics card (GTX 1060) as soon as I can, and I want to upgrade to ubuntu 18.04 soon, too. Will provide feedback on those updates here when I have them.
I’m currently on Ubuntu 16.04, AMD - A8-7600 3.1GHz Quad-Core Processor and Gigabyte - GA-F2A68HM-H Micro ATX FM2+ Motherboard, for reference.


  • Tested on my Intel system, with GTX 1060
    Getting a steady 60 - 70fps on ultra
    Shader cache seems to fill faster (might be because of previous games, not sure)

I had an audio issue where if I left a voice channel the client would freeze. That’s no longer happening (same goes for the other install script, too)

CPU: Intel - Core i7-7700K 4.2GHz Quad-Core Processor
MOBO: MSI - B250 PC MATE ATX LGA1151 Motherboard
GPU: Zotac - GeForce GTX 1060 6GB 6GB Mini Video Card


  • On my AMD system, with the graphics card in, monitor connected via HDMI -> VGA adapter:
    Getting this error when I launch OW:

The Blizzard app launches fine. Doesn’t look like I’ll get it to work with the GPU until I can upgrade my monitor.


  • On my AMD system, Ubuntu 18.04, with the graphics card plugged in via HDMI -> VGA adapter:
    Overwatch won’t install.
    The install script says all went well, but when I launch the game I get this error:


When I check the program files folder, there’s no Battle.Net folder. I believe I’ve encountered this issue before and just had to keep retrying the installation until it worked. I’ve retried it at least 5 or 6 times for the night and no success.

I’ll try troubleshooting this, but any help would be appreciated.

AMD System, running on Ubuntu 18.04

Same problem here

Install dependencies, as stated on https://github.com/lutris/lutris/wiki/Game:-Blizzard-App

1 Like

Thanks Dox, after I posted I realize that i didn’t read the fine print :laughing:
Everything is working now

I thought I got everything. I’ll reinstall everything just to be sure.

Got it installed, but I’m still getting this error:


Might this be because I’m connecting my monitor to the graphics card via an adapter?

You need newer driver for DXVK 0.60+. (Or use DXVK 0.54 with older drivers)

Installed the proprietary nvidia drivers, and it worked. I was able to play a game just fine. Shader cache may be worse, but that may be because I had my graphics set to medium.