Back to the main site

Overwatch doesn't start, crashes at start [The application encountered an unexpected error]


#1

Hello, dear users. I have a huge problem with Overwatch, it is not playing nice with my Linux install, Manjaro 18.0.4 Gnome Stable. I followed all instructions described in the wiki, and also desperately tried to find an topic with a similar problem, with no avail. The Battle . net works normally, but the game crashes as soon as it starts.
I tried with Wine 4.0, 4.5-shader-validator, provided by Lutris, and 4.6, both by Lutris and by the official Manjaro repository. DXVK and Esync are all enabled. My Kernel is 5.0.9-2.

I also should point out that the script provided for Overwatch’s installation is currently not working properly, I had to use the workaround posted in the Github

And now, the logs. Since they are actually huge, I posted them on Pastebin.

I hope my description helps solving that problem. Thanks in advance for your time.

edit I also tried submit this as an issue directly from the terminal using --submit-issue, do I have to upload the .json anywhere, or it has been already received by someone? I’m not used to work with Github