Overwatch - Battle.Net Helper.exe has encountered a problem

After the latest OW and Battle.Net update I’m getting this error (https://imgur.com/a/fziv3). The game won’t launch anymore. Should I maybe reinstall Battle.Net? I don’t think this is an issue with Overwatch itself.

Tried installing Battle.Net launcher itself, and it seems to be fine until I click on the Overwatch tab or the Overwatch League button at the top (latest patch).
Hearthstone received the update and opens fine whether or not I click on the Overwatch League button.

I think the way you have your overwatch or battlenet install done is a bit off. I own all the Bnet games except Destiny 2, and all play and run just fine. Now a few do require a few extra steps. But they do indeed run.


The only thing I didnt put in there is the last patch or so has ramped up the bogus Battle Net helper box that pops up on some game launches and some bnet page loads./

That’s really comprehensive. I managed to get the game to open by killing Helper.exe, but I think I’ll try out your solution when I get the time.

Depends on what version of Wine you are using. 3.0 RC4 actually solved that Steam problem. Don’t know about helper.exe. I think it’s a external for updates to be upgraded (since it’s not open source it’s hard to guess).

Though I don’t get the same problem with staging-2.21-x86_64 version with Battle.net. The only problem I get is Hearthstone, when I close it it actually crashes right at the end.