Overwatch 2 "The application encountered an unrecoverable error" on startup

When launching Overwatch 2 from BattleNet a very vague error occurs every time.
It reads “The application encountered an unrecoverable error. Click “OK” to create a memory dump, then please share it on our support site.”
After closing the popup game does something like a 5-10 second update or checkup for no reason.
The launcher itself works perfectly.
Tried both with Lutris and Bottles (caffe 7.20, caffe 7.18, lutris-7.2-2, soda-7.0-7).
Fresh installed Linux Mint, all dependencies from the github links on the install page installed (I hope), GPU supports Vulkan.

General system info:
Linux Mint 21 Cinnamon
Kernel 5.15.0-52-generic
AMD Athlon II X4 CPU
AMD Radeon HD 7870 GPU

Issue report, Lutris -d output, game log and error screenshot:


An update on the error so far - this is probably a game issue.
Vulkan was tested through other games, like Starcraft II from the same launcher, worked fine on my machine.
Changing around runners didn’t help.
Drivers are not the issue either.

I have the same problem, and tried many wine versions, even different distros. I have a xeon x3450 and rx 570, maybe the problem is with my older hardware but the game works on windows.

On vanilla wine 7.20 the game doesn’t launch but the error doesn’t appear.

As far i’ve gathered this is unlikely a hardware issue, except for some integrated intel graphics users.
Did you try any other games besides Overwatch?

all the games I tested works, overwatch 2 itself worked in beta but now it doesn’t work anymore.

The Same “The application encountered an unrecoverable error. Click “OK” to create a memory dump, then please share it on our support site.” happens on my system.
My specs:
Core2Quad Q8300
GT 1030
I’ve also tried 4-5 distros, different wine versions inlcuding Caffe 7.18, all dependencies of wine and lutris are installed, but still getting the same error everytime. Sometimes it changes to “The Application encountered an Unexpected Error…”.
Maybe It’s only happening on older hardware.
I don’t have the Log files with me, but it read something like "Encountered unknown instruction at memory address ".
So, I think it’s because of some instruction missing in the older processors.
It works completely fine on Windows.
I had to ditch Linux because of it.

i tested overwatch 2 today and it worked, i think blizzard fixed the problem because i didn’t change anything in lutris.