Back to the main site

Outdated nvidia driver

I installed Lutris on Linux Mint and when i launch it it says my nvidia driver is outdated. My video card is NVIDIA Quadro 1000M and the driver that i have installed is 390.138. Lutris says i have to install nvidia 450 driver but i don’t see my card in the list of supported devices from this driver. There is Quadro M1000M in the supported list, but my card is Quadro 1000M. Should i try to install the newer version of nvidia driver or there is no point?