Origin - online login is currently unavailable

when I install origin everything works fine but it’s unable to connect internet.

It’s same issue that is described here:

but I’ve tried all these workarounds and even more like different settings of system time and others I don’t even remeber, it’s already a few days of cruel fight.
I’m pretty sure that problem is somehow sticked to hardware. When I tried this on the same distro (Manjaro KDE) with same configuration, tools and versions but different machine, Origin worked with no problem. Also tried on this other machine in fedora and it works. (but it has just intel iGPU) And that machine I’m using now has dualboot with windows, I tried install Origin in windows and it also works.

Does somebody know what I could do? Thanks.

Did u use the installer on lutris or did you install manually?

did you try opening the ports needed for Origin?

  • TCP : 80, 443, 9960-9969, 1024-1124, 3216, 18000, 18120, 18060, 27900, 28910, 29900
  • UDP : 1024-1124, 18000, 29900

I tried installer and also manual installation but with manual instalation the log in window was all black and I guess it had same problem with connection. And I also tried install Mirror’s Edge Catalyst true steam which requires origin account, origin had installed normally than on the login windows >> online login is currently unavailable. The same problem always.

And ports are opened. I even tried origin before installation of firewall. And like I sat before: on the same distro with same configuration just with different hardware it works like a charm. Looks like this will be pretty hidden problem.

Thans for your response.

And I forgot to mention: I also tried to update by ./updateorigin.sh