[not lutris' fault] [winesteam] network unavailable

I tried to install the winesteam runner, after the Steam msi was downloaded, when Wine ran for the first time it asked me to install mono but it failed to download it. After the installation, when I tried to run Steam it aborted saying network was not available.

Of course network was available (the Steam msi was downloaded fine, for example, and other runners install nicely, and networked games work well), but Wine itself was not able to download that Mono stuff and Steam running in Wine is not able to connect to Steam servers.

The Wine version used was staging-2.6-i386, but it’s unrelated to the bug since the bug also occurs when I use within lutris other Wine versions installed on my system. If I use any wine installed on my system, it both failed to download mono and to connect Steam. Outside of lutris, network works, within lutris, network does not work.

Steam is displaying “To run Steam you must connect to the Internet” before aborting.

ok, that’s weird…

Can you try the same thing with LUTRIS_RUNTIME=0 lutris -d ?

DEBUG    2017-05-13 09:15:11,513 [desktopapps]:Found desktop game "Sudoku" (app: gnome-sudoku, slug: sudoku)
DEBUG    2017-05-13 09:15:11,844 [runtime]:Runtime disabled, not updating it.
INFO     2017-05-13 09:15:11,844 [lutriswindow]:Connected to lutris.net as illwieckz
DEBUG    2017-05-13 09:15:11,850 [api]:Fetching game library
DEBUG    2017-05-13 09:15:19,107 [thread]:Command env: WINEARCH="win32" WINEPREFIX="/home/illwieckz/.local/share/lutris/runners/winesteam/prefix" WINEDEBUG="-all" WINE="/home/illwieckz/.local/share/lutris/runners/wine/staging-2.6-i386/bin/wine" 
DEBUG    2017-05-13 09:15:19,108 [thread]:Running command: "/home/illwieckz/.local/share/lutris/runners/wine/staging-2.6-i386/bin/wine" "/home/illwieckz/.local/share/lutris/runners/winesteam/prefix/drive_c/Program Files/Steam/Steam.exe" "-no-cef-sandbox"
DEBUG    2017-05-13 09:15:19,108 [thread]:Storing environment variable WINEARCH to win32
DEBUG    2017-05-13 09:15:19,108 [thread]:Storing environment variable WINEPREFIX to /home/illwieckz/.local/share/lutris/runners/winesteam/prefix
DEBUG    2017-05-13 09:15:19,108 [thread]:Storing environment variable WINEDEBUG to -all
DEBUG    2017-05-13 09:15:19,108 [thread]:Storing environment variable WINE to /home/illwieckz/.local/share/lutris/runners/wine/staging-2.6-i386/bin/wine

(network still failing)

Was not a lutris bug, the issue is in something like NetworkManager or related service that configures a faulty local DNS resolver. Setting the IP address of my DNS resolver in /etc/resolv.conf instead of the local configured by NetworkManager fixed the issue.

[Edit: I got the same issue within a game running in PlayOnLinux, and got the same issue using Linux native steacmd to install a native linux server, that’s how I figured out it was not lutris’ fault.]

Something very similar happened to me a few weeks ago where I would have to change /etc/resolv.conf to use to get net access on a bunch of stuff.

The amount of stuff it was affecting was insane: Wine games, LXD containers, VMWare VMs and pretty much everything that wasn’t basic web browsing.

I have no idea how I fixed it, but I finally managed to get working properly (It involved a lot of fiddling around with systemd, dnsmasq and network-manager) :smiley:

I have my own router with my own DNS resolver and cache for my own network living on a separate device, but something in my system decided to not use it (or to use it wrong). I just had to set the IP of my own device to fix it, something NetworkManager must do by itself since DHCP provides that IP address as DNS resolver. I still don’t know where to report that bug but it looks like I’m not the only one who suffered from this. :unamused: