Not loading Steam games after recent Big Picture Mode update

As the title says, after the recent (and pretty janky!) Big Picture Mode update in Steam, I try to load a Steam game up through Lutris, Steam loads up and then the game doesn’t start at all, this always worked before.
Tried the .deb version of Lutris and Steam and the Flatpak version of both Lutris and Steam with everything set up correctly using both methods, firstly uninstalling the .deb versions and then with Steam Flatpak version symlink to set up the ~/.steam as per instructions found on Lutris Forums etc which worked well (I will link what I did to get Flatpak Steam to be recognised in Flatpak Lutris)
Here’s how I got Flatpak Lutris to recognise Flatpak Steam.

I think Lutris needs to be updated to be able to deal with the recent Steam update.


1 Like

Quick little update:

Have tried without steam opening in Big Picture Mode, and Lutris can still launch games when it’s in Desktop mode, but not the new update with the new Steam Big Picture Mode.

1 Like

2nd update:

I found that 3 things are also happening:

  1. The game will run in Steam Desktop Mode, but as it goes to run Lutris toggles minimized and then just goes back to as it was before, doesn’t matter if it’s full as is or using Compiz Fusion Settings Manger set to Full Screen (which is great with Lutris with side bar turned of just on Games, and leave it like that most of the time).

  2. After you shut the game down Steam does NOT shut down, it stays minimised.

  3. With Steam minimized in the background, Lutris has game pad support for navigating and choosing a game?! WHAT?! That’s never happened before, and only if Steam is running. So somehow to add gamepad support, the Lutris DEV team need to look into that and work out how they can implement that into Lutris, as that is actually pretty useful, although part of a bug, strangely.

1 Like