Back to the main site

Nintendo switch pro controller not working in lutris

A good day to you all!

I am on archlinux + xanmod-rt

I have a new nintendo switch pro controller, which works fine with steam, but i cant get it to work with lutris.

Anyone out there has managed to get this controller work fine with lutris ?

Any recommendations are appreciated!

Well it’s kind of hard to use an input device when you don’t have a driver for it…

Steam provides their own evdev-based driver for the Switch Pro Controller, but you’re going to have a bad time trying to use it outside of Steam.

There’s a kernel driver called hid-nintendo, it was originally planned to be merged for 5.10, but the developer cancelled the plans and is going to merge it at a later date, I guess. There’s a repo for the dkms module at https://github.com/nicman23/dkms-hid-nintendo

Clone the repo, and follow the three-line instructions.

Then, whenever you want to use the controller, run sudo modprobe hid_nintendo, then connect the controller (you can use bluetooth or usb, both work fine). Make sure Steam isn’t open, or they’ll conflict.

If you want to use Steam and the hid_nintendo module is loaded, just unload it with sudo modprobe -r hid_nintendo.

You can find more information here: https://wiki.archlinux.org/index.php/Gamepad#Nintendo_Switch_Pro_Controller_and_Joy-Cons

Hey there!

Thank you for taking the time to reply, much appreciated!

sadly i had already tried that. I even tried again just in case i missed anything, but no luck.

epic games still reflects no input from the controller.

any other ideas ?

I was not able to have the controller directly working on epic games by any means i could online.

The only option i found is running epic games through steam, so that steam drivers for the controller kick in. This works, and is the workaround I am using, but it is such a disappointment to jump through all the hoops to get the controller working. I may move over to steam i guess.