New launcher crashing

I suspect this is a general WINE problem, but I thought I’d mention it. just released a new launcher to consolidate the launchers for several of their games. Unfortunately, it immediately crashes with a generic “Restart/Close” Windows crash dialog. Has anyone else noticed or experienced this problem?

I’d include the output of lutris -d and lutris --submit-issue but the forum is telling me “New users can only include 2 links”…whatever that means. I didn’t include any links, so presumably it’s interpreting some logging output as hyperlinks and it’s thinking I’m a spammer.

I haven’t. The launcher starts fine for me. I have installed both World of Warships and World of Tanks. The games, however, just hang when I launch them. I get the black screen and it freezes until I kill the process from a terminal.

Well, did some poking at it tonight and got WoWs to work.

Can you confirm the following?

For the launcher, ensure ESync is off. With it on, my launcher crashed.

Once the game is installed, try running from the launcher. If your install is like mine, it’ll fail. If so, try running the game’s exe directly using the “Run Exe in inside wine prefix”. That is what worked for me. Launching the game from the launcher fails. Launching it directly works.

Last update tonight. Confirmed that World of Tanks starts via the same method. Crashes from launcher.

For the launcher, ensure ESync is off. With it on, my launcher crashed.

Esync was already off for me.

Maybe the issue is that I already had the game installed (World of Warships), and there’s some problem with the new installer upgrading the old game?

If so, try running the game’s exe directly using the “Run Exe in inside wine prefix”.

I don’t see any option that matches this inside the Configure dialog. Where can I find it?

Looks like I can post links now.

lutris -d output:

lutris --submit-issue output:

I now see the “Run EXE inside wine prefix” option you mentioned, but it didn’t work for me.

I tried running ~/Games/world-of-warships/drive_c/Games/World_of_Warships/WorldOfWarships.exe but all that does is launch a small black window containing no graphics.

Yeah, I did a fresh install of the launcher from this script. So I’m not sure if updating from the old install to a new one is the problem, only that in my case, in trying to diagnose the issue, I did a complete fresh install and it is working. Which is a pain given the download size of the games.

Quick edit. Looks like something is amiss with your connection to Wargaming. They are returning a 404 to the link the updater or game is trying to download:

GET /launcher/game_part_install_started?installation_id=2ea89e57e882538d1e024d29accc751679802505&tracking_id=&event_date=2020-06-10%2020%3a42%3a10%20-0400&application_id=wows&session_id=3BE6FC924158C6282ABE688D58C0B1F8&app_type_id=incomplete&chain_id=h15&game_language=en&launcher_version_from=unknown&launcher_version_to=3.29.980&transaction_id=8A666BB545F823722EEC3DA7B30F99AE HTTP/1.1
User-Agent: wg::http::curl_http_request 1.1
Accept: /

< HTTP/1.1 404 Not Found


I just tried deleting everything and reinstalling from scratch, but the new “Game Center” installer still crashes almost immediately.

I may have spoken too soon. The installer initially gives me a “Restart/Close” dialog, which I thought meant the entire process had crashed, but I noticed that after I click “Close” the installer then completes. I’m now downloading the WOWS which seems to be proceeding correctly.

You’re right, the trick seems to be to install the Wargaming Game Center from the Lutris library, not the old game-specific installers, which are probably all broken now.

No luck. I was able to install Game Center, and WOWS, but the game immediately crashes after launching.

If I run the WorldOfWarships.exe using the “Run EXE inside wine prefix” dialog, that shows a small black window, and I hear the startup sound effect, but nothing renders. However, it doesn’t crash either or give me an error dialog.

I finally figured it out. Running lutris -d, I noticed this in the terminal log:

warn: Skipping Vulkan 1.0 adapter: GeForce GT 1030
warn: DXVK: No adapters found. Please check your device filter settings and Vulkan setup.
D3D11CreateDevice: No default adapter available

So I disabled the “Enable DXVK” setting, and bam, it runs perfectly. It looks like the Vulkan graphics interface doesn’t work with Wine on my system, and disabling it fixes everything.

I can start WOT if I use it via “Run EXE inside wine prefix” dialog. Without DXVK graphics do not work right, land is mostly black.
I have radeon 5700rx

Launching lutris through the commandline with lutris WoT and WoWS now works.
I do not know why, but it does.
Wine: lutris-5.7-3
DXVK: 1.7
OS: OpenSUSE Tumbleweed
CPU: 2600X
GPU: Vega 64

I can only make the Launcher work with Windows 7 selected, and only make World of Warships work with Windows 10 selected. It would be nice to be able to run the launcher as Win 10 so you don’t have to switch back and forth…

Well, now even starting from Run EXE inside Wine Prefix fails for me. Running WorldofWarships.exe now notices that the WGC isn’t running, runs it and exits. Hitting play in WGC for WoWs or WoT starts them, but both terminate unexpectedly.

It’s broken for me again. WoWS detected a new version available and required I upgrade. So I launched WGC and the upgrade happened. Then the WGC window turned completely black. I let it sit for an hour, but eventually was forced to kill it. Now trying to launch WoWS also just results in a black window.

I tried deleting everything and reinstalling from scratch, but the same thing happens.

It looks like something’s immediately crashing after launch, as this is what’s shown in the terminal for lutris -d:

Running /home/chris/.local/share/lutris/runners/wine/lutris-5.7-5-x86_64/bin/wine /home/chris/Games/wargaming-game-center/drive_c/Program Files (x86)/
Initial process has started with pid 28201
Game is considered started.
[0710/] WSALookupServiceBegin failed with: 0
[0710/] WSALookupServiceBegin failed with: 0
[0710/084723.302:INFO:CONSOLE(1)] “[webChannel] connection established.”, source: qrc:/ui/main.6ed5077b98147510ee46.js (1)
Initial process has exited.
Game is considered exited.
All monitored processes have exited.
Exit with returncode 0
DEBUG 2020-07-10 08:47:38,585 [command.on_stop:182]:The process has terminated with code 0
DEBUG 2020-07-10 08:47:38,586 [command.stop:266]:Management process looks dead already.
DEBUG 2020-07-10 08:47:38,586 [command.stop:274]:Detaching logger

After reinstall, I also received the error “No file provided”. Checking the Game Options settings, it looks like the current installer no longer initializes the values for “Executable” or “Wine prefix”. Setting these manually to ~/Games/wargaming-game-center/drive_c/Program Files (x86)/ and ~/Games/wargaming-game-center respectively fixes this…I think. I don’t remember exactly what the old values were.