New Install Script Needed For Elder Scrolls Online

Zenimax Online updated the launcher for The Elder Scrolls Online this week and it broke the game for many people.According to people I asked Windows users were given Microsoft Visual C++ 2015-2022 Redistributable (x64) - 14.38.33135 at the same time as the launcher update so their game files matched the new launcher versions.

Wine/Lutris users aren’t so lucky and i have had a terrible time trying to update the files. i can’t seem to get the game to recognize the new files unless i change wine parameters but doing so breaks other things.

I used the “Wine Standalone version” last published 1 year, 5 months ago it worked great but is most likely a dud now.

i would really appreciate someone who knows how to write scripts to have a look at updating the ESO script.

By all means feel free to test.
A change to the Visual C++ runtime - if you view the YAML, you’ll see the following task…

- task:
    app: vcrun2010
    arch: win64
    description: Installing vcrun2010

…however, a quick change and test confirms that although it installs VC++ 2022 into the prefix and downloads and installs the launcher, it wouldn’t run on click. The zip file that used to be part of the launcher has changed. I needed to unpack extra content before the launcher would run.

That said, I’m not on a decent connection (to download ~100GB of data) or even have a Bethesda account to install and test the game, someone with a more vested interest can do that :slight_smile:

Diff between the two YAML files : -

<       app: vcrun2010
>       app: vcrun2022
<       description: Installing vcrun2010
>       description: Installing vcrun2022
>   - execute:
>       command: echo "mkdir -p '$GAMEDIR/tmp/Launcher'"
>         > '$GAMEDIR/tmp/'
>       description: Extracting launcher files
>   - execute:
>       command: echo "unzip '$GAMEDIR/drive_c/Program Files (x86)/Zenimax Online/Launcher/'
>         -d '$GAMEDIR/tmp/Launcher/'" >> '$GAMEDIR/tmp/'
>       description: Extracting launcher files
>   - execute:
>       command: chmod +x '$GAMEDIR/tmp/'
>       description: Extracting launcher files
>   - execute:
>       args: $GAMEDIR/tmp/
>       description: Extracting launcher files
>       file: /usr/bin/bash
>   - merge:
>       dst: $GAMEDIR/drive_c/Program Files (x86)/Zenimax Online/Launcher
>       src: $GAMEDIR/tmp/Launcher

…with the assumption default path for launcher to find the necessary zip file, it installs ok with “lutris -i esonew.yml” and the launcher runs, behaves as expected and is waiting for you to click install.

1 Like

Can confirm that this works all the way to playing the game without issues.

Elder Scrolls Online, Standalone
CachyOS Linux, Lutris 0.5.17, wine-ge-8-26-x86_64

I will test this out. How did you view the yaml for the runtime?

I will make the changes to the game yaml and test on my incomplete test install and then do a complete install. Could I replace the launcher folder in my current install and run the launcher with the changes? Would that work?

That’s great! Did you do a new install or did overwrite your current install?
Did you need anything to edit the yaml or just a text editor?

Update: Thanks for the replies! i had submitted a support ticket when this issue first popped up and after we closed it the responder suggested I send some of my ideas as feedback.

Zenimax probably doesn’t support Linux because of the small Linux user base and variety of distros. If they supported Lutris they would help us Linux users at no cost except a bit of time to update the ESO script.

Since I moved to Linux I spent over $1000 dollars on chapters and subscriptions. According to the Lutris ESO page: 5176 users have this game. If they all spent as much as me then the total is $5,176,000.

I think Zenimax should have an employee periodically update Lutris scripts.

The installer has a drop-down on the Lutris game page, that you can click to “view installer script” - select the YAML tab and you’ll see the text. Copy that text to “eso.yml” - make sure the formatted indentation stays exactly as it is, YAML is picky :slight_smile:
Copy the block of text I pasted into a new file “eso.diff” (again, preserve the spacing) then merge the two with patch

patch eso.yml eso.diff

…then invoke Lutris to install it from the command line with

lutris -i eso.yml

… after you click the Install button, you can specify a new directory and it will create an entirely new WINE prefix where it will be installed.
You will get two identical icons for ESO - make sure you check the properties before you remove the extra!

Side note: Lutris doesn’t exit after running lutris -i and leaves itself in the CLI - once it is done, just launch the GUI and run the game.

1 Like

It’s a completely new install on a completely fresh Linux (I switched from Void to Cachy)

Use the patch command as explained by Asaftiifm.

Good luck, and have fun.

Thanks! It didn’t work the first time I tried it but I found what I did wrong and tried again. The launcher is a bit fiddly but I am able to launch the game okay and the game runs great.

Thanks, and thanks for replying! It didn’t work for me the first time but because it worked for you I went back at it. I found the mistake I made and fixed it and now I can launch the game and play! The launcher is still a bit fiddly but it works.